Intel® Aero Platform For UAVs
Peer-to-peer support only
Announcements
This is a peer-to-peer only forum. This forum is not monitored by Intel.

LTE software for UBUNTU?

idata
Community Manager
1,267 Views

I have ubuntu-16.04.3 running on my intel aero board. This will simplify my prototyping so thanks to intel for getting this done. The question is, that it does not appear that the software for the LTE modem that's in the intel yocto-poky tree, is in 16.04.3 . Can someone from intel clarify if the LTE build was only build into the yocto tree? If so how do I get installers for the LTE modem so I can run it on UBUNTU?

thanks in advance

0 Kudos
3 Replies
idata
Community Manager
214 Views

Hello irieblue,

 

 

Thank you for your interest in the Intel Aero Compute Board.

 

 

You can follow the instructions from https://github.com/intel-aero/meta-intel-aero/wiki/91-(References)-LTE-Modems LTE Modems Aero as they should also work with Ubuntu 16.04, booted into the kernel 4.4.76-aero-1.2

 

 

Please let us know the outcome!

 

 

Thank you,

 

Eliza
idata
Community Manager
214 Views

running mmcli yields the following output : Once I get a SIM card, I will try to establish a connection. The confusion is that the standard network panel does not seem to think there is a WWAN LTE modem

roger@Aero:~$ mmcli -m 0

/org/freedesktop/ModemManager1/Modem/0 (device id '8991082ec94bddf0b40b8d9156b77f8872590b93')

-------------------------

Hardware | manufacturer: 'Sierra'

| model: 'MBIM [1199:A001]'

| revision: 'FIH7160_V1.2_WW_01.1415.07'

| supported: 'gsm-umts, lte'

| current: 'gsm-umts, lte'

| equipment id: '013937006256182'

-------------------------

System | device: '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3'

| drivers: 'cdc_acm, cdc_mbim'

| plugin: 'Sierra'

| primary port: 'cdc-wdm0'

| ports: 'cdc-wdm0 (mbim), ttyACM0 (at), wwp0s20u3 (net)'

-------------------------

Numbers | own : 'unknown'

-------------------------

Status | lock: 'unknown'

| unlock retries: 'unknown'

| state: 'failed'

| failed reason: 'sim-missing'

| power state: 'on'

| access tech: 'unknown'

| signal quality: '0' (cached)

-------------------------

Modes | supported: 'allowed: 2g, 3g, 4g; preferred: none'

| current: 'allowed: any; preferred: none'

-------------------------

Bands | supported: 'unknown'

| current: 'unknown'

-------------------------

IP | supported: 'ipv4, ipv6, ipv4v6'

-------------------------

SIM | path: 'none'

-------------------------

Bearers | paths: 'none'

idata
Community Manager
214 Views

Hello irieblue,

Thank you for the output.

After you get the SIM card, please let us know the outcome.

 

Please make sure that under Status, you will have: lock: 'none'  state: 'registered'

Thank you in advance,

 

Eliza
Reply