Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ALysn
Novice
1,091 Views

Mavlink-router fails when arming throttle, loses connection with QGroundControl

Jump to solution

Hi,

 

I am having issues using mavlink-router. When Intel Aero boots, mavlink-router works as it should and I am able to connect using QGroundControl. However, once I arm the drone the connection breaks and QGroundControl stays at "COMMUNICATION LOST". Disarming the drone does nothing, and the only way to get the connection back is to power the drone off and then on again. Using the reboot-command does not do anything either. SSH still works.

 

 

Output of aero-get-version.py:

 

BIOS_VERSION = Aero-01.00.16

OS_VERSION = Ubuntu 16.04.6 LTS"

AIRMAP_VERSION = unknown

FPGA_VERSION = 0xc2

AeroFC firmware version = 3.6.7

 

 

 

main.conf in /etc/mavlink-router:

[General]

TcpServerPort=5760

ReportStats=false

Log=/var/lib/mavlink-router/

 

[UartEndpoint uart]

Device = /dev/ttyS1

Baud = 921600,460800

 

[UdpEndpoint wifi]

Mode = Normal

Address = 192.168.8.255

 

[UdpEndpoint ethernet-over-usb]

Mode = Normal

Address = 192.168.7.255

 

[UdpEndpoint csd]

Mode = Normal

Address = 0.0.0.0

Port = 80550

Mode = eavesdropping

 

 

 

status after mavlink-router fails:

 

aero@aero-CherryTrail:/$ sudo etc/init.d/mavlink-routerd.sh status

● mavlink-router.service - MAVLink Router

  Loaded: loaded (/lib/systemd/system/mavlink-router.service; enabled; vendor preset: enabled)

  Active: failed (Result: start-limit-hit) since to. 2016-02-11 17:34:48 CET; 581ms ago

 Process: 2391 ExecStart=/usr/bin/mavlink-routerd (code=dumped, signal=SEGV)

 Process: 2387 ExecStartPre=/bin/bash -c echo 4 > /sys/class/tty/ttyS1/rx_trig_bytes (code=exited, status=0/SUCCESS)

 Main PID: 2391 (code=dumped, signal=SEGV)

 

feb. 11 17:34:48 aero-CherryTrail systemd[1]: mavlink-router.service: Unit entered failed state.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: mavlink-router.service: Failed with result 'core-dump'.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: mavlink-router.service: Service hold-off time over, scheduling restart.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: Stopped MAVLink Router.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: mavlink-router.service: Start request repeated too quickly.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: Failed to start MAVLink Router.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: mavlink-router.service: Unit entered failed state.

feb. 11 17:34:48 aero-CherryTrail systemd[1]: mavlink-router.service: Failed with result 'start-limit-hit'.

 

 

Any help is appreciated!

0 Kudos
1 Solution
ALysn
Novice
423 Views

Hi Eliza,

 

Found a fix. I was using arducopter firmware version 3.6.7 downloaded from their site (http://firmware.ardupilot.org/Copter/stable/aerofc-v1/). I reflashed the FC with the default px4 that is stored in /dev/aerofc/px4, and everything works as it should. Thank you for your help!

 

Anders

View solution in original post

4 Replies
Eliza_D_Intel
Employee
423 Views
Hello ALysn, Thank you for your interest in the Intel Aero Ready to Fly drone. Could you please test if you notice the same behavior when having only "460800" as baudrate? You mentioned that after arming the motors, you receive the "communication lost" message on QGC (I assume that on the laptop). How are you able to disarm the motors if the connection with QGC is lost? Are you doing it from the drone itself? How are you powering up the drone? Are you using a battery or a wall power supply? Thank you and best regards, Eliza
ALysn
Novice
423 Views

Hey,

 

I set the baudrate to "460800", but with this baudrate i was not able to connect using QGC at all. Changing it back to 921600 made QGC able to connect, but the problem persists.

 

When the motors arm, I beleive a failsafe is triggered (Ground station failsafe is set to Enabled always RTL) which after a short while disarms the motors. Also, after the communication with QGC is lost and the RTL failsasfe is completed, I am still able to arm and disarm Intel Aero with the radio transmitter.

 

I have tried powering the drone from both a wall socket and battery. The wall socket is not powerful enough to arm the motors, and Intel Aero powers off whenever I try. My battery provides enough power, but the communication is lost after arming.

 

As a side note: I had this problem while running Yocto Linux as well.

 

Thanks for your help!

Eliza_D_Intel
Employee
423 Views
Hello ALysn, Thank you! Could you please make sure that you have the firewall disabled on your laptop when you connect the drone to QGC? Also, could you try restarting the service and provide us the status output: sudo systemctl restart mavlink-router sudo systemctl status mavlink-router Thank you and best regards, Eliza
ALysn
Novice
424 Views

Hi Eliza,

 

Found a fix. I was using arducopter firmware version 3.6.7 downloaded from their site (http://firmware.ardupilot.org/Copter/stable/aerofc-v1/). I reflashed the FC with the default px4 that is stored in /dev/aerofc/px4, and everything works as it should. Thank you for your help!

 

Anders

View solution in original post

Reply