Intel® Aero Platform For UAVs
Peer-to-peer support only
Announcements
This is a peer-to-peer only forum. This forum is not monitored by Intel.
775 Discussions

Not receiving HIGHRES_IMU message

UNaal
Beginner
1,437 Views

Hi All,

I have been tinkering with the optical flow example provided for intel aero drone. After some debugging I found that I am not receiving the MAVLINK_MSG_ID_HIGHRES_IMU message which is essential to the program. Note that I have tried this on two separate drones but I am using ArduPilot firmware.

- Do I need to have the PX4 firmware to receive this message or is it possible to have this message generated while using ArduPilot?

Thank you

0 Kudos
1 Solution
idata
Community Manager
202 Views

Hello u.naal,

 

 

 

Thank you for your interest in the Intel Aero Compute Board.

 

 

I have done some research and as far as we know, the message is not available in Ardupilot, in the optical flow instructions it states that PX4 needs to be build and installed.

 

 

I would like to suggest you try it with PX4. You can find information on the following link .

 

 

https://github.com/intel-aero/aero-optical-flow https://github.com/intel-aero/aero-optical-flow

 

"build and install the latest stable PX4"

 

 

 

Let me know if this is helpful,

 

 

Regards,

 

Casandra

View solution in original post

1 Reply
idata
Community Manager
203 Views

Hello u.naal,

 

 

 

Thank you for your interest in the Intel Aero Compute Board.

 

 

I have done some research and as far as we know, the message is not available in Ardupilot, in the optical flow instructions it states that PX4 needs to be build and installed.

 

 

I would like to suggest you try it with PX4. You can find information on the following link .

 

 

https://github.com/intel-aero/aero-optical-flow https://github.com/intel-aero/aero-optical-flow

 

"build and install the latest stable PX4"

 

 

 

Let me know if this is helpful,

 

 

Regards,

 

Casandra
Reply