Intel® Aero Platform For UAVs
Peer-to-peer support only
Announcements
This is a peer-to-peer only forum. This forum is not monitored by Intel.
775 Discussions

PREFLIGHT FAIL: NO MAG SENSOR 0

Skodge
Beginner
2,000 Views

I just got a new Intel Aero RTF drone. Upon updating the flight controller firmware to 1.6.5, I get a preflight fail error in QGroundControl while calibrating the controller. I've tried updating the firware to the stable releases 1.7.3 and 1.8.1 but still I get the same error.

The flight controller used to work out of the box without any updates, so I am pretty sure the hardware is fine.

I found out by looking into other threads on this forum that this might happen because of the firmware version and 1.6.5 was concluded to be a stable version which had everything working fine. But, it doesnt work for me.

Kindly help!

0 Kudos
8 Replies
Eliza_D_Intel
Employee
252 Views

Hello Skodge,

 

 

Thank you for your interest in the Intel Aero Ready to Fly drone.

 

Can you please perform a Airframe Reset firstly, and then calibrate the drone? Please make sure to calibrate all the sensors - https://github.com/intel-aero/meta-intel-aero/wiki/02-Initial-Setup#calibration

 

Also, what is your current output of:

aero-get-version.py

 

Thank you and best regards,

Eliza

Skodge
Beginner
252 Views

We tried a Airframe Reset, unfortunately the issue was not resolved by this.

Please find the output of "aero-get-version.py"

Skodge
Beginner
252 Views
Alexandra_C_Intel
252 Views
Hi Skodge, Can you try running the command "commander calibrate mag" in Mavlink Console? If this doesn't work either, can you please tell me the output of the command below? nsh> ls /dev/ Regards, Alexandra
Skodge
Beginner
252 Views

"commander calibrate mag" in Mavlink Console did not work.

Please find the output of nsh>ls/dev/

 

ls_dev.jpg

Thanks

Alexandra_C_Intel
252 Views
Hi Skodge, It seems to be a hardware issue since the sensor is not detected. Can you please ensure your external GPS/mag is properly connected? Regards, Alexandra
Alexandra_C_Intel
252 Views
Hi Skodge, Do you still need help with this issue? Regards, Alexandra
RobinX
Novice
252 Views

I am having the same issue with this problem, but not only GPS, but also compass sensor. I can ensure that all connection is good and flashed all original files you provided on GitHub several times, still no luck.

Reply