Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Hang_L_Intel
Employee
2,468 Views

Problems of installing ubuntu on Aero

Jump to solution

Hi all, when I followed the wiki (https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation 90 (References) OS user Installation · intel-aero/meta-intel-aero Wiki · GitHub ) to install

ubuntu on Aero, I had several problems:

(1) I installed the yocto embedded linux first and updated bios, flashed flight controller, fpga successfully, the apt-get-version.py reported

currect versions of the bios, fpga and fc. Then I installed ubuntu, and when I finished and installed the aero repository,

the versions of fpga and fc got from apt-get-version.py were unknown, but the wiki said the fpga and fc will be kept. This is the first

problem.

(2) I decided to reinstall fpga and fc, there are two problems:

1) I successfully flased the fpga, but the versions of fpga were still unknown when I typed apt-get-version.py.

2) I could not flash the flight controller, as it reported "unable to read force bootloader pin value".

(3) The mavlink seemed not to be installed successfully, as when I type "sudo systemctl restart mavlink-router",

it reported "Job for mavlink-router.service failed because the control process exited with error code".

Look forward to your responce.Intel_JesusCommunityAdmin

0 Kudos
1 Solution
SNET1
New Contributor I
317 Views

I found the answer.

https://github.com/intel-aero/meta-intel-aero/issues/291 Cannot connect to flight controller and FPGA after Ubuntu installation · Issue # 291 · intel-aero/meta-intel-aero · GitHu…

According to the above link, it is related with Linux kernel.

By following https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation# get-version 90 (References) OS user Installation · intel-aero/meta-intel-aero Wiki · GitHub,

when you power on the intel aero rtf, you can see GRUB screen.

I always choose the first one.....then the kernel version is the following..

$ uname -a 

Linux intel-aero-rtf-ubuntu 4.10.0-28-generic # 32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

But, we need the version of Linux 4.4.x to install FPGA and FC!!

So how to choose Linux 4.4.x version of kernel?

Turn on the intel aero rtf... and in GRUB, you can see the default boot mode is the second one... press enter key... then you can see Linux 4.4.x...

That is, it is already set to select Linux 4.4.x kernel.............

I did not know why GRUB default set as like that...

Anyhow.. it is solved...

So keep setting up your intel drone by following https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation# get-version 90 (References) OS user Installation · intel-aero/meta-intel-aero Wiki · GitHub

Thank you.

View solution in original post

5 Replies
idata
Community Manager
317 Views

Hello, aeroAn

 

 

Thank you for contacting Intel Customer Support.

 

In order to help you further, I need to ask you a few questions first:

 

1. Are you running get_aero_version.py with sudo?

 

2. Are you booting into Ubuntu with the right Kernel?

 

https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation# checks https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation# checks

 

3. Are using sudo to flash the flight controller?

 

 

This may be due to not selecting the right kernel. If any of this doesn't solve, try re-installing Ubuntu and let us know if there are any errors during the initial setup and configuration.

 

 

Regards,

 

Alexandra
JDiam3
Beginner
317 Views

I'm having similar problems after trying to install ubuntu on my drone. Alexandra, in response to your questions:

1. Yes, I'm running "sudo aero-get-version.py" which returns:

BIOS_VERSION = Aero-01.00.13

OS_VERSION = Ubuntu 16.04.3 LTS"

AIRMAP_VERSION = unkown

FPGA_VERSION = 0xc2

AeroFC firmware version = unknown

2. Yes, I'm booting into ubuntu with the correct kernel: "uname -a" returns "Linux 4.4.76-aero-1.2 # 1 ...

3. Yes, I'm using sudo to flash the flight controller, which appears to finish successfully. However, the "sudo aero-get-version.py" still returns "AeroFC firmware version = unknown"

SNET1
New Contributor I
317 Views

I have also the same problem.

1.

$ sudo get_aero_version.py

BIOS_VERSION = Aero-01.00.13

OS_VERSION = Ubuntu 16.04.3 LTS"

AIRMAP_VERSION = unknown

FPGA_VERSION = unknown

AeroFC firmware version = unknown

2.

$ uname -a

Linux intel-aero-rtf-ubuntu 4.10.0-28-generic # 32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

SNET1
New Contributor I
318 Views

I found the answer.

https://github.com/intel-aero/meta-intel-aero/issues/291 Cannot connect to flight controller and FPGA after Ubuntu installation · Issue # 291 · intel-aero/meta-intel-aero · GitHu…

According to the above link, it is related with Linux kernel.

By following https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation# get-version 90 (References) OS user Installation · intel-aero/meta-intel-aero Wiki · GitHub,

when you power on the intel aero rtf, you can see GRUB screen.

I always choose the first one.....then the kernel version is the following..

$ uname -a 

Linux intel-aero-rtf-ubuntu 4.10.0-28-generic # 32~16.04.2-Ubuntu SMP Thu Jul 20 10:19:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

But, we need the version of Linux 4.4.x to install FPGA and FC!!

So how to choose Linux 4.4.x version of kernel?

Turn on the intel aero rtf... and in GRUB, you can see the default boot mode is the second one... press enter key... then you can see Linux 4.4.x...

That is, it is already set to select Linux 4.4.x kernel.............

I did not know why GRUB default set as like that...

Anyhow.. it is solved...

So keep setting up your intel drone by following https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation# get-version 90 (References) OS user Installation · intel-aero/meta-intel-aero Wiki · GitHub

Thank you.

View solution in original post

idata
Community Manager
317 Views

Hi,

 

 

Ubuntu needs to boot into the correct kernel. You should not select a different kernel, it will automatically boot into the correct one.

 

 

Regards,

 

Alexandra

 

 

Reply