Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ZChen57
Beginner
866 Views

QGroudControl keeps saying failsafe enabled: no offboard mode

When I run my code, first I set it to offboard mode successfully, then I publish position data to the drone every 0.3 seconds, then QGC keeps saying "failsafe enabled: no offboard mode". But I get the current mode in my code and it remains in offboard mode. I set rate = rospy.Rate(10.0).

Who can explain this to me? How should I make changes to get rid of this warning from QGC? Thanks in advance.

0 Kudos
1 Reply
ZChen57
Beginner
127 Views

I solved this by making some changes in QGC, thanks.

Reply