Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RSmit16
Novice
1,691 Views

Question about LTE modem performance with Sierra Wireless 7345 Modem

Jump to solution

I finally got a test SIM to try with my Aero setup on T-Mobile here in northern california . The card was provisioned as a pre-paid plan . I told T-mobile I wanted to try their network with an iPad. The card was provisioned with the following APN's

 

+CGDCONT: 1,"IPV4V6","alpha.mnc260.mcc310.gprs","",0,0,0,0,0,0

+CGDCONT: 2,"IPV4V6","phone","",0,0,0,0,0,0

 

When I popped the Sim into the Aero/Sierra Wireless 7345 setup (with some some basic 3" circuit board antennas . ( AT+CSQ returns : +CSQ: 3,20 for the signal strength.)

 

The cellular performance , and surf speed are awful (see ping times below).

 

Is there anything I can try with my configuration to speed this up. Will changing the APN to "fast.t-mobile.com" really make a difference? I am surprised the modem just connected without any initiation. Which PDP context did it pick for the connection?

 

 

~$ ping www.apple.com

PING e6858.dsce9.akamaiedge.net (23.62.159.145) 56(84) bytes of data.

64 bytes from a23-62-159-145.deploy.static.akamaitechnologies.com (23.62.159.145): icmp_seq=22 ttl=56 time=6466 ms

64 bytes from a23-62-159-145.deploy.static.akamaitechnologies.com (23.62.159.145): icmp_seq=23 ttl=56 time=7098 ms

64 bytes from a23-62-159-145.deploy.static.akamaitechnologies.com (23.62.159.145): icmp_seq=24 ttl=56 time=6862 ms

 

Here is my setup..

 

root@fadec:~$ ifconfig -a

can0   Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 

     NOARP MTU:16 Metric:1

     RX packets:0 errors:0 dropped:0 overruns:0 frame:0

     TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:10 

     RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

 

lo    Link encap:Local Loopback 

     inet addr:127.0.0.1 Mask:255.0.0.0

     inet6 addr: ::1/128 Scope:Host

     UP LOOPBACK RUNNING MTU:65536 Metric:1

     RX packets:276328 errors:0 dropped:0 overruns:0 frame:0

     TX packets:276328 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:1 

     RX bytes:13826798 (13.8 MB) TX bytes:13826798 (13.8 MB)

 

sit0   Link encap:IPv6-in-IPv4 

     inet6 addr: ::22.167.92.154/96 Scope:Compat

     inet6 addr: ::127.0.0.1/96 Scope:Unknown

     inet6 addr: ::192.168.8.1/96 Scope:Compat

     inet6 addr: ::192.168.7.2/96 Scope:Compat

     UP RUNNING NOARP MTU:1480 Metric:1

     RX packets:0 errors:0 dropped:0 overruns:0 frame:0

     TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:1 

     RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

 

usb0   Link encap:Ethernet HWaddr 72:03:f4:d2:3d:ae 

     inet addr:192.168.7.2 Bcast:192.168.7.255 Mask:255.255.255.0

     BROADCAST MULTICAST MTU:1500 Metric:1

     RX packets:0 errors:0 dropped:0 overruns:0 frame:0

     TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:1000 

     RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

 

wlp1s0  Link encap:Ethernet HWaddr 00:c2:c6:d3:03:c4 

     BROADCAST MULTICAST MTU:1500 Metric:1

     RX packets:0 errors:0 dropped:0 overruns:0 frame:0

     TX packets:70 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:1000 

     RX bytes:0 (0.0 B) TX bytes:11089 (11.0 KB)

 

wwp0s20u3 Link encap:Ethernet HWaddr f6:02:d2:7f:b2:d7 

     inet addr:22.167.92.154 Bcast:22.167.92.255 Mask:255.255.255.0

     inet6 addr: 2607:fb90:482:e004:f527:977e:6813:efa5/64 Scope:Global

     inet6 addr: 2607:fb90:482:e004:1990:33c2:a9dd:ec09/64 Scope:Global

     inet6 addr: fe80::26:83b5:aa01/120 Scope:Link

     UP BROADCAST RUNNING NOARP MULTICAST MTU:1428 Metric:1

     RX packets:147 errors:0 dropped:0 overruns:0 frame:0

     TX packets:55719 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:1000 

     RX bytes:16482 (16.4 KB) TX bytes:50571102 (50.5 MB)

OK

 

+CGDCONT: 1,"IPV4V6","alpha.mnc260.mcc310.gprs","",0,0,0,0,0,0

 

+CGDCONT: 2,"IPV4V6","phone","",0,0,0,0,0,0

 

 

+CSQ: 3,20

 

 

root@fadec:~$ mmcli -m 0

 

/org/freedesktop/ModemManager1/Modem/0 (device id '8991082ec94bddf0b40b8d9156b77f8872590b93')

 -------------------------

 Hardware | manufacturer: 'Sierra'

      |     model: 'MBIM [1199:A001]'

      |   revision: 'FIH7160_V1.2_WW_01.1415.07'

      |   supported: 'gsm-umts, lte'

      |    current: 'gsm-umts, lte'

      | equipment id: '01393700625xxxx

 -------------------------

 System |    device: '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3'

      |    drivers: 'cdc_acm, cdc_mbim'

      |    plugin: 'Sierra'

      | primary port: 'cdc-wdm0'

      |     ports: 'cdc-wdm0 (mbim), ttyACM0 (at), wwp0s20u3 (net)'

 -------------------------

 Numbers |     own : '+1xxxx043242'

 -------------------------

 Status |     lock: 'none'

      | unlock retries: 'sim-pin2 (10)'

      |     state: 'connected'

      |  power state: 'on'

      |  access tech: 'lte'

      | signal quality: '0' (cached)

 -------------------------

 Modes  |   supported: 'allowed: 2g, 3g, 4g; preferred: none'

      |    current: 'allowed: 2g, 3g, 4g; preferred: none'

 -------------------------

 Bands  |   supported: 'unknown'

      |    current: 'unknown'

 -------------------------

 IP   |   supported: 'ipv4, ipv6, ipv4v6'

 -------------------------

 3GPP  |     imei: '013937006256182'

      | enabled locks: 'fixed-dialing'

      |  operator id: '310260'

      | operator name: 'T-Mobile '

      | subscription: 'unknown'

      | registration: 'home'

 -------------------------

 SIM   |     path: '/org/freedesktop/ModemManager1/SIM/0'

 

 -------------------------

 Bearers |     paths: '/org/freedesktop/ModemManager1/Bearer/0'

 

 

root@fadec:~$ nmcli device

DEVICE  TYPE   STATE    CONNECTION 

cdc-wdm0 gsm   connected  modem   

sit0   iptunnel disconnected --     

wlp1s0  wifi   unavailable --     

can0   can   unmanaged  --     

usb0   ethernet unmanaged  --     

lo    loopback unmanaged  --     

 

0 Kudos
1 Solution
RSmit16
Novice
214 Views

Hi Alexandra,

 

Here is the output:

 

A quick update however. I disabled the mavlink daemon, rebooted this morning, and the performance is fine for what I would expect from the XMM 7160 modem . I didn't change anything on the wireless configuration.

 

See some speed tests here:

 

http://www.speedtest.net/result/7890489858

http://www.speedtest.net/result/7890506582

http://www.speedtest.net/result/7890512431

http://www.speedtest.net/result/7890517030

 

The ping times and data rates are acceptable .

 

I think we can close this issue.

 

mmcli -m 0

 

/org/freedesktop/ModemManager1/Modem/0 (device id '8991082ec94bddf0b40b8d9156b77f8872590b93')

 -------------------------

 Hardware | manufacturer: 'Sierra'

      |     model: 'MBIM [1199:A001]'

      |   revision: 'FIH7160_V1.2_WW_01.1415.07'

      |   supported: 'gsm-umts, lte'

      |    current: 'gsm-umts, lte'

      | equipment id: 'XXXX37006256182'

 -------------------------

 System |    device: '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3'

      |    drivers: 'cdc_acm, cdc_mbim'

      |    plugin: 'Sierra'

      | primary port: 'cdc-wdm0'

      |     ports: 'cdc-wdm0 (mbim), ttyACM0 (at), wwp0s20u3 (net)'

 -------------------------

 Numbers |     own : '+XXXX2043242'

 -------------------------

 Status |     lock: 'none'

      | unlock retries: 'sim-pin2 (10)'

      |     state: 'connected'

      |  power state: 'on'

      |  access tech: 'lte'

      | signal quality: '0' (cached)

 -------------------------

 Modes  |   supported: 'allowed: 2g, 3g, 4g; preferred: none'

      |    current: 'allowed: 2g, 3g, 4g; preferred: none'

 -------------------------

 Bands  |   supported: 'unknown'

      |    current: 'unknown'

 -------------------------

 IP   |   supported: 'ipv4, ipv6, ipv4v6'

 -------------------------

 3GPP  |     imei: '013937006256182'

      | enabled locks: 'fixed-dialing'

      |  operator id: '310260'

      | operator name: 'T-Mobile '

      | subscription: 'unknown'

      | registration: 'home'

 -------------------------

 SIM   |     path: '/org/freedesktop/ModemManager1/SIM/0'

 

 -------------------------

 Bearers |     paths: '/org/freedesktop/ModemManager1/Bearer/0'

 

root@fadec:~# mmcli -b 0

Bearer '/org/freedesktop/ModemManager1/Bearer/0'

 -------------------------

 Status      | connected: 'yes'

           | suspended: 'no'

           | interface: 'wwp0s20u3'

           | IP timeout: '20'

 -------------------------

 Properties    |    apn: 'phone'

           |  roaming: 'allowed'

           |  IP type: 'ipv4v6'

           |    user: 'none'

           |  password: 'none'

           |   number: '*99#'

           | Rm protocol: 'unknown'

 -------------------------

 IPv4 configuration | method: 'static'

           | address: '22.160.215.107'

           | prefix: '24'

           | gateway: '22.160.215.1'

           |   DNS: '10.177.0.34', '10.177.0.210'

 -------------------------

 IPv6 configuration | method: 'dhcp'

           | address: 'fe80::26:8490:5001'

           | prefix: '120'

           | gateway: '16a0:d76b:fe80::1'

           |   DNS: 'fd00:976a::9', 'fd00:976a::10'

 

View solution in original post

2 Replies
214 Views
Hi Roger, Thank you for your interest in the Intel Aero Compute Board. Could you tell me the output of these commands? sudo nmcli -m 0 sudo nmcli -b 0 Regards, Alexandra
RSmit16
Novice
215 Views

Hi Alexandra,

 

Here is the output:

 

A quick update however. I disabled the mavlink daemon, rebooted this morning, and the performance is fine for what I would expect from the XMM 7160 modem . I didn't change anything on the wireless configuration.

 

See some speed tests here:

 

http://www.speedtest.net/result/7890489858

http://www.speedtest.net/result/7890506582

http://www.speedtest.net/result/7890512431

http://www.speedtest.net/result/7890517030

 

The ping times and data rates are acceptable .

 

I think we can close this issue.

 

mmcli -m 0

 

/org/freedesktop/ModemManager1/Modem/0 (device id '8991082ec94bddf0b40b8d9156b77f8872590b93')

 -------------------------

 Hardware | manufacturer: 'Sierra'

      |     model: 'MBIM [1199:A001]'

      |   revision: 'FIH7160_V1.2_WW_01.1415.07'

      |   supported: 'gsm-umts, lte'

      |    current: 'gsm-umts, lte'

      | equipment id: 'XXXX37006256182'

 -------------------------

 System |    device: '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3'

      |    drivers: 'cdc_acm, cdc_mbim'

      |    plugin: 'Sierra'

      | primary port: 'cdc-wdm0'

      |     ports: 'cdc-wdm0 (mbim), ttyACM0 (at), wwp0s20u3 (net)'

 -------------------------

 Numbers |     own : '+XXXX2043242'

 -------------------------

 Status |     lock: 'none'

      | unlock retries: 'sim-pin2 (10)'

      |     state: 'connected'

      |  power state: 'on'

      |  access tech: 'lte'

      | signal quality: '0' (cached)

 -------------------------

 Modes  |   supported: 'allowed: 2g, 3g, 4g; preferred: none'

      |    current: 'allowed: 2g, 3g, 4g; preferred: none'

 -------------------------

 Bands  |   supported: 'unknown'

      |    current: 'unknown'

 -------------------------

 IP   |   supported: 'ipv4, ipv6, ipv4v6'

 -------------------------

 3GPP  |     imei: '013937006256182'

      | enabled locks: 'fixed-dialing'

      |  operator id: '310260'

      | operator name: 'T-Mobile '

      | subscription: 'unknown'

      | registration: 'home'

 -------------------------

 SIM   |     path: '/org/freedesktop/ModemManager1/SIM/0'

 

 -------------------------

 Bearers |     paths: '/org/freedesktop/ModemManager1/Bearer/0'

 

root@fadec:~# mmcli -b 0

Bearer '/org/freedesktop/ModemManager1/Bearer/0'

 -------------------------

 Status      | connected: 'yes'

           | suspended: 'no'

           | interface: 'wwp0s20u3'

           | IP timeout: '20'

 -------------------------

 Properties    |    apn: 'phone'

           |  roaming: 'allowed'

           |  IP type: 'ipv4v6'

           |    user: 'none'

           |  password: 'none'

           |   number: '*99#'

           | Rm protocol: 'unknown'

 -------------------------

 IPv4 configuration | method: 'static'

           | address: '22.160.215.107'

           | prefix: '24'

           | gateway: '22.160.215.1'

           |   DNS: '10.177.0.34', '10.177.0.210'

 -------------------------

 IPv6 configuration | method: 'dhcp'

           | address: 'fe80::26:8490:5001'

           | prefix: '120'

           | gateway: '16a0:d76b:fe80::1'

           |   DNS: 'fd00:976a::9', 'fd00:976a::10'

 

View solution in original post

Reply