Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JChow2
Beginner
1,419 Views

ROS and Ubuntu on Intel Aero RTF Drone

Like others in the community, I have also replaced the supported OS with Ubuntu 14, an unsupported OS. I have a question about communicating with the flight controller. I'm trying to use mavros and launching the px4.launch file with fcu_url:=/dev/ttyS0:921600. Every thing is fine except no real useful data is being published. When I looked at the diagnostic information it says FCU connection not connected. Therefore I suspect /dev/ttyS0 is not correct, does anyone know what the proper connection should be? Thanks in advance.

Tags (1)
0 Kudos
2 Replies
78 Views

You should try to use /dev/ttyS1, and you will need to match the baudrate with the baudrate used by the firmware in question. If you're using the firmware that was shipped on the drone it should be 1500000, otherwise it will depend on how it was compiled.

JChow2
Beginner
78 Views

/dev/ttyS1 is what I tried to do at first, but when I run roslaunch mavros px4.launch fcu_url:=/dev/ttyS0 it returns no errors, even though it ran and all the topics were listed, nothing is actually published because the FCU is not connected based on the diagnostic. When I run roslaunch mavros px4.launch fcu_url:=/dev/ttyS1 ROS simply tells me there is a I/O error and the node has to shutdown.

Moreover, following a link on the Intel Aero Github Wiki, it pointed me here: https://github.com/guermonprez/IntelAero1/wiki/04-Autonomous-drone-programming-in-Python 04 Autonomous drone programming in Python · guermonprez/IntelAero1 Wiki · GitHub where it suggested to use /dev/ttyS0 on Ubuntu 16.

Reply