Community
cancel
Showing results for 
Search instead for 
Did you mean: 
XShi1
Beginner
975 Views

Some success on running mavros on serial port

Hi all,

I noticed that some people are trying to run mavros on the drone and are having problem with it, I myself included. I wanted to share some successes I had.

What I've noticed is that even after stopping mavlink-routerd, mavros will have problem connecting to /dev/ttyS1 outputting the error serial0: receive: End of file, as if the port is still in use.

Here is what I did that made it work eventually:

I disabled mavlink-routerd from startup by deleting S71mavlink-routerd from /etc/rc1.d through rc5.d ( I guess you can also modify or comment out the start() function in /etc/init.d/mavlink_routerd.sh)

Then after restarts, I can run roslaucnh mavros px4.launch fcu_url:=/dev/ttyS1:460800.

Note: 1 . this worked consistently for me after a power cycle, but the serial0:receive End of file error message should be gone instantly.

 

2. I haven't tried gcs reroute through mavros yet.

-XS

0 Kudos
1 Reply
KShan1
Beginner
49 Views

Works for me! I don't really care for the GCS pass through, so this is exactly the hotfix I need for now.

Reply