Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LFerr7
New Contributor I
1,450 Views

Tcpdump output shows Aero always broadcasting UDP packets

Jump to solution

Hello everyone,

for curiosity I ran the command:

sudo tcpdump -i wlp1s0

on my Aero with Ubuntu 16.04 (BIOS, Pixhawk and FPGA up-to-date) and the output is:

15:00:07.700555 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.700586 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 44

15:00:07.705873 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.705939 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.716590 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 74

15:00:07.716724 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.716782 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 44

15:00:07.716835 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.720820 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.726366 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.726435 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.726480 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.735634 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.736773 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 74

15:00:07.737272 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.737303 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 44

15:00:07.738089 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.741313 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.755482 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 40

15:00:07.757767 IP 192.168.8.1.45781 > 192.168.8.255.14550: UDP, length 74

I was wondering if all those broadcast packets are MAVlink packets (heatbeats? GPS requests?) but the port is 14550.

Can someone give me some insights about it?

Is that broadcasting decreasing wifi performance?

0 Kudos
1 Solution
DMadi
New Contributor I
148 Views

I believe port 14550 is being used by the mavlink-router service. You can easily confirm it by running "systemctl stop mavlink-router" to temporarily disable the mavlink-router service, try your tcpdump again, and then re-start the mavlink-router using the command "systemctl start mavlink-router".

Regards,

Dan

View solution in original post

3 Replies
idata
Community Manager
148 Views

Hello Ludovico,

 

 

Thank you for your interest in the Intel Aero drone.

 

 

Your request has been received and is currently being investigated.

 

We will get back to you as soon as possible.

 

 

Regards,

 

Octavian
DMadi
New Contributor I
149 Views

I believe port 14550 is being used by the mavlink-router service. You can easily confirm it by running "systemctl stop mavlink-router" to temporarily disable the mavlink-router service, try your tcpdump again, and then re-start the mavlink-router using the command "systemctl start mavlink-router".

Regards,

Dan

View solution in original post

LFerr7
New Contributor I
148 Views

You were right!

Is port 14550 used by the RFC?

Intel tells you to create a Tcp connections over the loopback address on port 5760 to communicate with the Pixhawk so I'm speculating they keep that port for the RFC.

Reply