Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JBros
Beginner
2,267 Views

Upload trouble into the intel Drone : "Waiting for the bootloader ..."

Hello,

I'm currently working with the intel drone below :

https://click.intel.com/intel-aero-ready-to-fly-drone.html Intel® Aero Ready to Fly Drone - Intel® Aero Platform Developer Kits

I would like to transfert some code from Matlab-Simulink by using the PSP solution below :

https://www.mathworks.com/hardware-support/pixhawk.html Pixhawk PX4 Support from Embedded Coder - Hardware Support - MATLAB & Simulin

To do so I configure some parameters in the "Configuration Parameters" of my Simulink simulation (Figure 1). The main one are in red rectangular below. Then I click apply.

Figure 1

In the next step I click on the build Icon inside the red square Figure 2. The building process seems to be perfomed properly as a succesfull message appears and some folder are created by the program at the root path.

Figure 2

Then I try to upload the program as you can see Figure 3.

Figure 3

Then the message Figure 4 appears and the program seems to be block here.

Figure 4

It looks like we have a connection problem or something is not launch correctly but we didn't really identify the cause of the problem and how to solve it...

Do you have any suggestion ?

Thank you,

Jeremy

0 Kudos
8 Replies
Octavian_C_Intel
Employee
249 Views

Hello Jeremy,

Thank you for your interest in the Intel Aero drone.

Have you updated the FPGA and the PX4 firmware?

Please run the aero-get-version.py command and share with me the output.

Regards,

Octavian

idata
Community Manager
249 Views

Hello Jeremy,

 

 

Do you still require assistance with this issue?

 

 

Regards,

 

Octavian
JBros
Beginner
249 Views

Hello Octavian,

Thank for you answer and sorry for the delay I didn't reveive any notification on your first reply.

I flashed everything by following the procedure here :https://github.com/intel-aero/meta-intel-aero/wiki/02-Initial-Setup 02 Initial Setup · intel-aero/meta-intel-aero Wiki · GitHub

So I suppose my set up is up to date.

The cmd aero-get-version.py from the intel aero compute board give (this command is not found from my computer):

Does it help?

Note that when I am trying to transfert a program from matlab the drone is connect to the computer from OTG to USB cable.

Thank you for your support,

Jeremy

idata
Community Manager
249 Views

Hello Jeremy,

 

 

Thank you for your reply.

 

 

It may be possible if there is a plug in for Matlab that supports Mavlink messages but we haven't tested the setup you are trying to use.

 

 

If you are connecting the drone to the computer through the OTG USB cable it will connect to the compute board but it won't connect to the flight controller so you need to connect to the flight controller by opening a terminal, connecting to the RTF through SSH and then use Mavlink in the terminal to connect to the flight controller.

 

Again, this hasn't been tested so we can't guarantee that it works.

 

 

Also how are you uploading the code to the flight controller on a regular pixhawk?

 

 

Regards,

 

Octavian

 

 

JBros
Beginner
249 Views

Hello Octavian,

Thank you for your reply and your time.

When trying to perform the procedure (build, then code>PX4 PSP: upload code to Px4 FMU)to a regular pixhawk the program display the following message :

When I set "build, load and run" instead of "build" Figure 1 I obtain :

I'm able to connect to the intel drone by ssh. But I don't know how to use Mavlink in the terminal to connect to the flight controller. Can you tell me how to do that or is it explain somewhere ?

As regards,

Jeremy

idata
Community Manager
249 Views

Hello Jeremy,

 

 

Thank you for your patience.

 

 

On the rtf, the board should already communicate with the FC if you have updated the firmware.

Check if the system is listening for MAVLink messages on port 5760 thanks to MAVLink router (for the Ready To Fly Drone only):

netstat -l|grep 5760

you should see:

tcp 0 0 *:5760 *:* LISTEN

If not, it's a problem. (You may have booted the wrong kernel, or something else is wrong)

 

 

The board communicates with the FC over the HSUART port. If you want to use a Pixhawk FC instead of the one in the RTF you can try the steps below also found on our wiki: https://github.com/intel-aero/meta-intel-aero/wiki/93-(References)-Pixhawk-FC

Depending on your use case, you can either disable the mavlink-router daemon and consume HSUART (/dev/ttyS1) locally on the Aero Compute Board OR configure mavlink-router to route incoming messages from the flight controller to Aero's access point, allowing you to communicate to the flight controller over WiFi.

Disabling mavlink router

From Aero's Linux shell, disable the mavlink-router daemon to free up the HSUART port. You can disable it with the following command.

 

/etc/init.d/mavlink-routerd.sh stop

Configuring mavlink router

By default, mavlink router is already setup to route packets between the flight controller and different IP endpoints. The only modification needed is to set the correct baud rate to be used on the HSUART. Normally, this is 57600 but can be different depending on how you configure Pixhawk.

Edit the file /etc/mavlink-router/main.conf and update the following with the correct baud.

[UartEndpoint uart]

 

Device = /dev/ttyS1

 

Baud = 57600

Restart mavlink router

/etc/init.d/mavlink-routerd.sh stop

 

/etc/init.d/mavlink-routerd.sh start  Hope this helps.

 

Regards,

 

Octavian
idata
Community Manager
249 Views

Hello Jeremy,

 

 

Do you require any more assistance with this issue?

 

 

Regards,

 

Octavian
JBros
Beginner
249 Views

Hello Octavian,

Yes please, I just worked on a other project in parallel recently and I didn't have the time to investigate.

But by the end of the week I will.

Thank you,

Jeremy

Reply