Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FDAlt
New Contributor I
1,841 Views

error message with Dronekit ERROR: wp index out of bounds

Jump to solution

Good evening,

I am using intel-aero drone and I am using dronekit to program it.

Unfortunately dronekit is not 100% fully compatible with px4 and sometimes it generates some problem.Now I am stuck in a situation where each script I launch prints on screen the following error

ERROR: wp index out of bounds

I have only found some discussion where someone said this message is related to a wrong mode assigned to the controller.

Can anyone has an idea to solve this issue?

Thanks to everybody for your support

Francesco

0 Kudos
1 Solution
FDAlt
New Contributor I
349 Views

I have solved the problem installing ardupilot first and then installing PX4 again.

Following the guide

cd /etc/aerofc/ardupilot/

aerofc-update.sh arducopter-aerofc-v1.px4

cd /etc/aerofc/px4/

aerofc-update.sh nuttx-aerofc-v1-default.px4

View solution in original post

5 Replies
idata
Community Manager
349 Views

Hello francesco.dalterio,

 

 

Thank you for your interest in the Intel Aero Ready to Fly Drone.

 

 

In regards to your query about the error message you are receiving in Dronekit, can you please tell me what versions of Dronekit and pymavlink you are running?

 

 

I found the following github post on the community: https://github.com/dronekit/dronekit-python/issues/724 is this what you also found?

 

 

Thank you,

 

Casandra

 

 

 

 

FDAlt
New Contributor I
349 Views

Thank you for your help Casandra.

Unfortunately, I already read that document and it didn't solve my problem

I have pymavlink 2.2.8 and dronekit 2.9.1

I am trying to change flight mode using the function PX4setMode(mavMode)

introduced in this guide about the usage of dronekit with PX4:

https://dev.px4.io/en/robotics/dronekit.html https://dev.px4.io/en/robotics/dronekit.html

but it is uneffective.

ICarr1
Beginner
349 Views

Hi Francesco,

As dronekit is not fully supported with PX4 I suggest you to try updating your flight controller to Ardupilot, dronekit works perfectly with it and you can find plenty information about it.

Regards.

idata
Community Manager
349 Views

Hello francesco.dalterio,

 

 

As ivanalexo mentioned our recommendation is also to try https://github.com/ArduPilot/ardupilot Ardupilot to see if the issue is seen there too.

 

I also recommend asking your question on the https://stackoverflow.com/questions/tagged/dronekit-python Dronekit community as they may have a solution for this.

 

 

Let me know if I can assist you with anything else.

 

 

Best regards,

 

Casandra
FDAlt
New Contributor I
350 Views

I have solved the problem installing ardupilot first and then installing PX4 again.

Following the guide

cd /etc/aerofc/ardupilot/

aerofc-update.sh arducopter-aerofc-v1.px4

cd /etc/aerofc/px4/

aerofc-update.sh nuttx-aerofc-v1-default.px4

View solution in original post

Reply