Intel® Aero Platform For UAVs
Peer-to-peer support only
This is a peer-to-peer only forum. This forum is not monitored by Intel.
776 Discussions

error there is a mavlink version or baud rate mismatch.


I followed all the steps in to connect the RTF with QGC on my ubuntu laptop. But i got an error message that QGCMessageBox (unit testing) "MAVLink Protocol" "There is a MAVLink Version or Baud Rate Mismatch. Please check if the baud rates of QGroundControl and your autopilot are the same."

Over on the RTF drone I see this after the gst-launch command:

root@intel-aero:~# gst-launch-1.0 v4l2src device=/dev/video13 do-timestamp=true ! video/x-raw, format=YUY2, width=640, height=480, framerate=15/1 ! autovideoconvert ! vaapih264enc ! rtph264pay ! udpsink host= port=5600

Setting pipeline to PAUSED ...

error: XDG_RUNTIME_DIR not set in the environment.

libva info: VA-API version 0.39.0

libva info: va_getDriverName() returns 0

libva info: Trying to open /usr/lib/dri/

libva info: Found init function __vaDriverInit_0_39

libva info: va_openDriver() returns 0

Pipeline is live and does not need PREROLL ...

Got context from element 'vaapiencodeh264-0': gst.vaapi.Display=context, gst.vaapi.Display=(GstVaapiDisplay)NULL;

Setting pipeline to PLAYING ...

New clock: GstSystemClock

i found no ways to match the baud rate of autopilot with qground control.Also i tried to

disabled the MAVLink router by running

/etc/init.d/ stop but unfortunately i found no file named in init.d directory but have a file named in the init.d directory.

0 Kudos
2 Replies

I ran into the same problem recently. I don't remember exactly, but I had forgotten to upgrade either the PX4 or the FPGA firmware when I updated to 1.5.1. When I upgraded the one I'd missed, the problem went away.

Community Manager

Hello Narveer,



I was wondering if you had the chance to check the suggestion provided by GabrielM.



If you have any update or question, don't hesitate to contact us.





Andres V.