Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
582 Views

hi. i have some questions about configuring the intel rtf drone.

for clarification,

·        i am running a Ubuntu 16.04 in the intel RTF. with kernel 4.4.76

·        Firmware 1.0.16 and FPGA 0xc2

·        and i tryng diferent autopilots... the px4 v1.82 and the ardupilot 3.67

·        have already installed the realsense camera, and can access to all its cameras locally using vl4 and trough rtsp

 

  • Cannot access the down and foward camera. how can i access.
  •  
  • In generall, in ardupilot cannot calibrate compass, as it sometimes its missing
  • i would like to install a TFMini lidar (uart version), which is supported in both px4v1.82 and ardupilot v3.67
    • i would like to verify the Telemetry pinout. In the intel-aero-compute-board-guide, its says that Tx is pin5. Its refers to board UART TX, or that i should put the TX of the lidar there
    • Do you have any recomendation to integrate the TFmini ?
  • in both firmwares, i have access to the nuttx terminal inside the flight controller. i would like to know wich ttyS is the telemetry port... int the board guide its says UART5.. its refer to ttyS4 ?
  • I see that the last version os yocto has the kernel 4.4.113 is there a way to update ubuntu to have this kernel? is there any advantage in doing this?
  • finally. i have purchased a MARVELMIND gps.. and would like to integrate it. do you have any knowledge for doing this ?

 

thanks.. and sorry if the mail is to long or has to many questions

0 Kudos
6 Replies
Highlighted
Moderator
39 Views

Hi MAlfo,

Thank you for reaching out. I will try to address your question in the same order.

  1. There is a known issue with the front facing 8 MP camera. This camera cannot be accessed at the moment. For the down facing camera, an rtsp stream is available. You can access the down facing camera with the following link rtsp://192.168.8.1:8554/bottom
  2. The TX pin is referring to the boards pin, you will need to connect the sensors RX pin to the TX pin on the board. Take a look at this older thread that is similar to your setup. https://forums.intel.com/s/question/0D50P0000490YKgSAM/how-to-connect-and-interact-with-tfmini
  3. It would take a significant amount of changes to update the Ubuntu Kernel. There are no additional software updates planned for the Intel Aero Platform, take a look at the discontinuation notice: https://www.intel.com/content/www/us/en/support/articles/000032327/drones/development-drones.html
  4. This Github discussion should help you to integrate the MARVELMIND GPS https://github.com/intel-aero/meta-intel-aero/issues/303

 

Regards,

Jesus

0 Kudos
Highlighted
Beginner
39 Views

thanks for the reply..

  1. this is a ubuntu problem? going back to yocto shoud bring the front camera back to work?
  2. For the downward camera, i have tryed the link.. with no luck (other like video13 works ok)
  3. I have succesfully connected the TFMINI, thanks for the boards descryptions. Also.. en PX4 1.82 the Nuttx terminal uses ttyS3 for this service
  4. OK with the kernel
  5. For marvelmind... i have send a email to them and recommended ardupilot wich they sayd they are compatible.. so im on it.

 

I have now flashed arducopter 3.67 and 3.7 downloaded from ardupilot webpage

 

  1. Do you now, in MissionPlanner or QGroundControl, wich serial number should be the telemetry port ?
  2. In general, the external IST8310 compass is not recognized by neither groundcontrol (MP or QGC), sometimes, it get detected but cannot calibrate. Have you experienced this ?

 

thanks

0 Kudos
Highlighted
Moderator
39 Views

Hi MAlfo, This is a known issue with the camera driver, the front camera does not function with Ubuntu or Yocto image. I recommend using the RGB camera on the Intel RealSense camera. The telemetry should automatically establish when connecting your computer running QGroundControl to the drones access point. I have seen the compass not being recognized after a software update. However, this is usually resolved with a frame reset. Regards, Jesus
0 Kudos
Highlighted
Beginner
39 Views

thanks jesus for the reply.

 

Currently... i have

  • Ardupilot 3.6.7
  • Compass calibration successfull... after a lotttttt of attemps. With QGC... using mavlink inspector... i saw that when the drone start... it sends the magnetomer data perfectly... but in time... it has less frecuency that the other IMY (accel and gyro).. and finally stop... but if i disconnect and connect again i start working again. Later... it will stop working again... So what i did is a disconnect - connect folowwed by a calibration... and it worked, more or less... i configured it as relaxed.
    • I tryed several times with frame reset... no luck.
  • Lidar TFMini working.
  • Marvelmind integrated as instructed with their manual
    • optical flow not compatible with this configuration
  • Still no downward camera streaming

 

So now that everything its UP.... i tryed to fly... no luck

  • with STABILIZE mode.. i can fly... but it not mantain altitud...
  • with ALTHOLD, AUTO, LOITER... when the throttle pass the 40-50% the copter flys UP UP and UP... the thing is that when i try to lower the throttle... it will have no push at all and start falling down...
  • Currently.... no more propellers... so i will need to wait like a month (i am in argentina) for new ones :(

 

regards

MA

0 Kudos
Highlighted
Moderator
39 Views

Hi MAlfo, Bummer! Please keep me posted when you are able to fly again. As I recommended your other thread, try to configure the drone with this setup using px4 and see if the behavior is the same. Regards, Jesus
0 Kudos
Highlighted
Beginner
39 Views

thanks.

yes... i am currently waiting for the propellers... should arrive at the end of the month... so i changed to other drone.

 

then i will do things.. carefully and a step based.

First... restore YOCTO or UBUNTU default with default autopilots

calibrate and FLY outside with default autopilot

update autopilot... fly safelly outside...

and then i wll pass to marvelmind... in the current approach... i skip the first....

 

thanks for your answers... i will keep you informed

 

regards

MA

0 Kudos