Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
8 Views

Adding "System Reference" to AMT machine from Visual Studio

I'm new to Intel AMT and I faced a problem when I tried to check it for the first time :

I tried to make a "Service Reference" to a configured vPro device, butI couldn't get the wsdl file. It asked for the username and password and when I enterd after a while I recieved an error message. I think it's related to HTTP Digest authentication. If anybody has used Visual Studio to use intel AMT in the same way please let me know how.

Thanks

0 Kudos
8 Replies
Highlighted
Moderator
8 Views

Hi and Thanks for posting your question on our forum!

Could you verify that you have configured WinRM correctly? You can reference Ajith's blog here for more details on WSman and WinRM.

Now if you have already done that, we will need more details:

  1. What sample are you calling and what are the exact arguments that you are calling it with?
  2. What version of AMT are you running?
  3. Are you provisioned in SMB? or Enterprise?
  4. Anything else you can share that might help us out?
0 Kudos
Highlighted
Beginner
8 Views

Hi,

Thanksfor your attention,

I'm not using WS-Man. I'm trying to use SOAP in a very small and simple application just tofigure out how it works,but this is my first experience with SOAP . I used Visual Studio's utility "Add Service" whichcreates the code for proxy class automatically. It asks for the URI to download the WSDL file and i entered this address :

http://localhost:16992/HardwareAssetService/?wsdl

but it then asks for credentials and I enter the credentials that I set for Intel AMT but I recieved an Error Message and it couldn't download the wsdl file. I'm using Intel AMT 2.5 on a notebook and provisioning mode is set in SMB.

I'm very new to SOAP and i may be misguided. Am I going the right direction?

0 Kudos
Highlighted
Moderator
8 Views

Oh yes... Of course you are using SOAP.... I am not familiar with adding services through Visual Studio so I will see if someone else has an idea of what might be the problem here. Since you are new to Intel AMT, you might look through the Start Here Guide and the SDK User Guidefor more information.

You can also try running some samples, if you haven't already done so. You can go to the bin folder in the SDK, and type in the .exe at a command prompt in order to see what the parameters are - for example if you want to run the "AssetDisplay" sample, the command line would look like:

>assetdisplay http:// address of AMT Client>:16992/HardwareAssetService -user -pass

Also, did you run the "makewsdls.bat"? You might want to also read through the "readme" file if you haven't already - they often have very good information in them.

Let us know if this helps and also if you have more questions.

0 Kudos
Highlighted
Employee
8 Views

All you need to to is create the proxy classes based on the SOAP WSDL files. From a Visual Studio Command Line (look in the "Visual Studio Tools" Start menu program folder of your Visual Studio installation to start the VS command prompt. Then, using the WSDL.EXE tool, you can easily generate the proxy classes from any WSDL file by passing in the full path and file name of the WSDL file to this tool. Look in the MSDN library for more information regarding the WSDL tool and the available command line options it provides. Or, if you still need asssistance, feel free to ask in this forum.

You'll need the latest AMT SDK to get the WSDL files that I'm referring to here - WindowsIntel AMT SDKIncludeWSDL.

0 Kudos
Highlighted
Beginner
8 Views

Thanks a lot. please tell me where i can find makewsdl.bat
0 Kudos
Highlighted
Beginner
8 Views

Thank you very much!

I managed to make it.

0 Kudos
Highlighted
Employee
8 Views

Hi,

Very glad to hear that the problem is resolved. May we request you to share your findings in this forum so it might help others in the future.

Thanks for updating the forum.

0 Kudos
Highlighted
Beginner
8 Views

Hi,

Problem:

When you try to use AMT services in Visual Studio by using "Add Reference" option you will encounter a problem. When request is sent to AMT's web server it responds with a request for credentials and you will see the window which asks for username and password. When you enter the credentials you will recieve an error message and WSDL file can not be downloaded.

Cause :

I belive this problem relates to authentication methods. Visual Studio sends the credentials by using HTTP Basic Authentication but AMT host is expecting them to be sent, usingHTTP Digest Authentication. That's why the connection is rejected by AMT host.

Solution :

Download Intel AMT SDK. The package contains WSDL files.use wsdl.exe to make the proxy class, then you can change the Port and Binding manually.

0 Kudos