Intel® Business Client Software Development
Support for Intel® vPro™ software development and technologies associated with Intel vPro platforms.

MeshCommander - Unable to push file (ERR500)

Arinci__Simone
Beginner
4,916 Views

Hello everyone, I'm trying to use the new nice feature of MeshCommander to load into AMT storage a mini version of MeshCommander, as described here:

MeshCommander Firmware Loader

The problem is that, both using MeshCommander or the standalone tool "MeshCommanderFirmware-0.7.1.exe", I always get the error: Unable to push file (ERR500): check that the computer is powered on. 

​​​​​​​

I successfully updated the ME firmware on Advantech PCs from v.11.0.12.1008 to latest v11.8.71.3630 to have this nice feature, but no joy! All the other Intel AMT functionalities seems to works well.

Any hints?

0 Kudos
1 Solution
Ylian_S_Intel
Employee
4,916 Views

Author here. Yes, this is due to a bug in the Intel AMT firmware. Attempting to push a file into Web Storage (the new version of 3rd Party Data Storage 3PDS) will result in a HTTP/500 error from the firmware. There does not seem to be a workaround for this until a new firmware is released that fixes it.

View solution in original post

0 Kudos
5 Replies
CBial
Beginner
4,916 Views

Hi!

I can only add - the same here! Using MeshCommander 0.8.2 (latest as of today).

With me it is happening on NUC7I5DNH with BIOS Version 0068-DNKBLi5v.86A.0068.2020.0312.1721 - ME 11.8.70.3626. With previous BIOS (BIOS Version 0067-DNKBLi5v.86A.0067.2019.1101.1757 - ME 11.8.65.3590) it worked ok.

So it seems there is now major compatibility issue between latest ME and MeshCommander.

0 Kudos
Ylian_S_Intel
Employee
4,917 Views

Author here. Yes, this is due to a bug in the Intel AMT firmware. Attempting to push a file into Web Storage (the new version of 3rd Party Data Storage 3PDS) will result in a HTTP/500 error from the firmware. There does not seem to be a workaround for this until a new firmware is released that fixes it.

0 Kudos
AndersTrier
Beginner
2,980 Views

I just want to confirm that upgrading the AMT firmware solves the problem.

 

Had the exact same issue with my Thinkpad T470 (vPro CPU: i7-7600U CPU) with AMT firmware 11.8.70.3626.

After updating the AMT firmware to 11.8.93.4323 I successfully loaded MeshCommander onto the AMT webserver!

 

Unfortunately Intel does not provide the AMT firmware updates directly. You'll have to check the download drivers section from your vendor. E.g I found the AMT firmware update for my platform on:

https://support.lenovo.com/us/en/product_security/LEN-14963#ThinkPad

 

If your vendor does not provide an updated AMT firmware image, you could try this out:

https://winraid.level1techs.com/t/intel-converged-security-management-engine-drivers-firmware-and-tools-2-15/30719

 

- Anders

0 Kudos
Arinci__Simone
Beginner
4,916 Views

Thanks for the reply Ylian. 

Are you aware if latest ME firmware available for my hw platform, v11.8.77.3664, fixes this issue?

Actually I'm using MeshCommander directly from the embedded web page on Intel AMT of a HP Z2 G4 workstation with ME firmware v12.0.64. Here the firmware download of MeshCommander worked like a charm!

Regards,

Simon

0 Kudos
CBial
Beginner
4,916 Views

Ylian S. (Blackbelt) wrote:

Author here. Yes, this is due to a bug in the Intel AMT firmware. Attempting to push a file into Web Storage (the new version of 3rd Party Data Storage 3PDS) will result in a HTTP/500 error from the firmware. There does not seem to be a workaround for this until a new firmware is released that fixes it.

Thank you for that!

Do we need to separatelly report ME error? And where? I've tried that for different problem (system defense filters which are not removable - link to the post is here) on Intel vPro forum but was spanked that MeshCommander is not supported tool so they do not care :-(

0 Kudos
Reply