Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Aaron_C_4
Beginner
976 Views

Wake on Lan, Windows 10 Pro, integrated 82567LM-3

I did a clean install to Windows 10 64 on this computer.  Since the upgrade, I cannot seem to get the Wake on Lan to work.  I have done the following:

- Made sure fast boot was turned off

- Made sure all was turned on under Power management of the Adapter (i.e. Allow device to wake the computer, allow magic packet, etc...)

- Set the ME Power control to S0, Wake in S3, S4-S5

I still cannot get the computer to WOL no matter what I did.  I think that I have it narrowed down to Intel doesn't have a specific driver for this card for Windows 10.  I installed the Window 7 64 bit driver and the WOL worked, but caused weird shutdown errors (BSOD, Bad Expool errors, etc...  This machine worked fine running Windows 7 with the same settings listed above.

Is there some way around this problem?  Is there a Ninja guide to WOL and settings that must be set?  How can an OS dictate if the machine wakes up or not?  

Thanks,

Aaron

0 Kudos
7 Replies
Joseph_O_Intel1
Employee
976 Views

Hey Aaron

if WoL isn't working in Win 10 with the default Ethernet driver, you will need to install a OS with a compatible driver for this NIC.

Might try the folks over in our Networking part of the Intel Developers Zone, they might have a trick that I am unaware of?

Joe

 

 

 

Claudiu_C_
Beginner
976 Views

Hi Aaron, for your NIC advanced settings on Windows 10 compared with Windows 7 do you see any changes?

Aaron_C_4
Beginner
976 Views

Yeah.  The drivers loaded, WOL worked.  Erroneous memory errors during shutdown, reboot, random.  I decided to go back to Windows 7 on my testing lab computers.

Claudiu_C_
Beginner
976 Views

I was referring to go in device manager to your NIC - properties - advanced - ... do you see any differences? meaning, first have a look to the default installation settings then when you force the w7 driver install, this should have other settings... what is different there? e.g. Reduce Speed on Power Down, SIPS etc.? I suggest to export from regedit the following: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318} and have a look at subkeys 0000, 0001 where you find your NICs, export them, compare them with a text compare utility and put here what is different... I might help you...

Claudiu_C_
Beginner
976 Views

Another quick try go to Ctrl-P MEBx and change to Host for all states don't let ME on any of those and check now.

fabrice_-_
Beginner
976 Views

If drivers support fail and the MEBX trick fail too, you can always boot your computer on a live linux distro to (re)enable WOL support. That's what i did for an aging 82567LF, it used to work properly on windows 7 but failed miserably after upgrading to Windows 10. Start a terminal and issue the following commands: sudo apt-get install ethtool then run the following command to enable WOL on ethX (where X is the Ethernet device number). sudo ethtool -s eth0 wol g Note: Not all devices support this. The settings can be verified by running: sudo ethtool eth0 Settings for eth0: Supported ports: [ MII ] Supported link modes: 10baseT/Half 10baseT/Full ... ... Supports Wake-on: g Wake-on: g Link detected: yes Note: "g" indicates wake on Magic Packet is enabled You're welcome :)
Aaron_C_4
Beginner
976 Views

Fabrice,

Thanks for the response.  I'm going to try and see if that works.

a.

Reply