Intel® C++ Compiler
Community support and assistance for creating C++ code that runs on platforms based on Intel® processors.
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

11.1 install fails on Mac

I just downloaded the Mac C++ compiler installer (m_cproc_p_11.1.088). If I mount the disk image, it verifies correctly. If I then double click on the installer, I first get a message, "The package will run a program to determine if the software can be installed" If I then click continue, I get a pop up:

Could not run startup script
Error while executing the startup script. Make sure that you have write permissions to /tmp, /Users/Shared/Library/Application Support/ and it's sub folders.

My only option then is to click "Close".
I am running the installer from an admin account.
I have tried a few things.
1) From the command line, I did:
sudo open /Volumes/m_cproc_p_11.1.088/m_cproc_p_11.1.088.mpkg
and I got exactly the same error.
2) I created a completely new admin account, switched to that and tried to install from there...
and got exactly the same result.
3) I tried to reboot the machine, just in case something was screwed change.

Any other suggestions?
I do have xcode installed. I am running 10.6.3 on a MacBook Pro. What is wrong with the installer?


0 Kudos
2 Replies
I got it work.
The key was to change the permissions of /Users/Shared/Library/Application\ Support/ from the default. Even though I am an admin, and even though I tried to run it with sudo, and even though the installer later asks for the admin password...twice, it still fails unless I did the following:
sudo chmod og+w /Users/Shared/Library/Application\ Support/

Then, after the install, I did this to set things back to the default:
sudo chmod og-w /Users/Shared/Library/Application\ Support/

New Contributor I
In my MacBook installation happened without any problem. The permission for the mentioned directory by default for me (I'm admin) is Read & Write and for others it is read only. I think first you install Xcode 3.2.1 and latter on icc. I don't see any problem should happen. Please be sure license is given correctly.