Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
88 Views

32-bit libraries needed to install C++ compiler on Linux

Hello

While installing ICC on a Debian linux system, I see this message:

Step 5 of 7 | Prerequisites > Missing Optional Prerequisite
--------------------------------------------------------------------------------
32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility libraries
when running on Intel(R) 64 architecture systems. One or more of these libraries
could not be found:
libstdc++ (including libstdc++6)
glibc
libgcc
Without these libraries, the compiler and the debugger will not function
properly.  Please refer to Release Notes for more information.
--------------------------------------------------------------------------------
1. Finish with prerequisites and continue installation [default]
2. Back to Prerequisite summary dialog

h. Help
b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [1]:

However I do have the latest versions of these libraries installed:
# apt-get install libgcc1:i386 libc6:i386 libstdc++6:i386
Reading package lists... Done
Building dependency tree     
Reading state information... Done
libgcc1:i386 is already the newest version.
libstdc++6:i386 is already the newest version.
libc6:i386 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.

Also added architecture i386 since my normal arch is amd64
# dpkg --print-foreign-architectures
i386

my command line:
./parallel_studio_xe_2015_update1_online.sh --cli-mode --ignore-signature

Debian version is Jessie D-I B2

I am only trying to install the C++ compiler portion, GDB and eclipse integration:
7. Intel(R) C++ Compiler XE 15.0 Update 1 [Custom]
12. GNU* GDB 7.7 [Custom]

What am I missing ? Any info would be great.

 

0 Kudos
7 Replies
Highlighted
Black Belt
88 Views

 

If you wish to install both the 32 and 64 bit intel compilers, both 32 and 64 bit g++ installations are needed.  normally you would select the configure option for intel64 omitting ia32.

0 Kudos
Highlighted
Beginner
88 Views

 

Thanks. Yes correct. Forgot to mention that I disabled the ia32 complier in the customization menu. I'm only interested in the 64 bit compiler.

However even with ia32 deselected in the installer I still see the message asking to install the 32 bit libs, and that the compiler "will not function properly" without them. I completed the installation anyway, and compiled some files with ICC. Everything worked OK as far as I can tell so far.

Can I assume this is a false positive error message in the installer?

thanks

0 Kudos
Highlighted
Employee
88 Views

Hi,

As long as you have de-selected all components that require 32bit libs then the compiler should install successfully without the message output. I'll file this issue with the developers and will update you accordingly, appreciate much.

_Kittur 

0 Kudos
Highlighted
Beginner
88 Views

Ok thanks. I would appreciate any updates.

0 Kudos
Highlighted
Employee
88 Views

BTW, I tried to install like you did on an equivalent EL system by de-selecting all the components needing 32-bit libs and it worked fine for me. Sure, I'll post any update I've accordingly.

_Kittur 

0 Kudos
Highlighted
Beginner
88 Views

Hi

In my exerperience the script parallel_studio_xe_2015_update1_online.sh has 2 problems:
1) It asks for 32 bit libs even though 32 bit support is de-selected
2) Even if 32 bit libs are installed, it cannot find them.

It looks like the problem is not in parallel_studio_xe_2015_update1_online.sh itself, but some other scripts that it downloads that handle the checking for libs and other env settings.

I tried l_ccompxe_online_2015.1.133.sh and it does not have the problem. This installer does not ask for 32 bit libs if 32 bit support is de-selected. It worked fine.


Thanks

0 Kudos
Highlighted
Employee
88 Views

Hi, Happy New Year to you!  Thanks for the info but unfortunately I couldn't reproduce the problem you mention on equivalent EL systems (don't have access to Debian sys).  

Nevertheless, I've passed on your issue to the development team responsible for the installation scripts so they can try on a Debian system and will keep you updated accordingly, appreciate much.

_Kittur 

0 Kudos