Intel® C++ Compiler
Community support and assistance for creating C++ code that runs on platforms based on Intel® processors.

Android crash with Intel Compiler


Hello!  I have hit a road block with the compiler and I am wondering if anyone out there has a solution.  I'll be as detailed as I can with my steps:

I am working with the newest version of INDE on Mac and have Update 2 of the Intel Compiler (per their suggestion)

I am trying to compare the speeds between arm , the intel compiler, and the intel compiler with options on 2 platforms- mac (Xcode) and android

My normal workflow is build and compile in Xcode, go to the android build folder and build in the command prompt using ndk-build, I then import the existing android code into Eclipse and run.  Easy.  No problems.  Anytime I try to use the intel compiler, either invoked through the command line or within eclipse, my android app crashes after a second or so of execution.

In the command line I tried: "ndk-build APP_ABI=x86 -ofast" (compiled just fine)

When I open in Eclipse and ran it crashed, so I tried compiling from within eclipse (properties-> C++ build -> build command: ndk-build APP_ABI=x86 -ofast) -- and it compiles, but as soon as I try to run, same crash. 

This is the error I get in Eclipse:

Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 6359 (any.neckrowbear)


And I have found that this may be an issue with accessing memory that is out of bounds but I have no clue... any ideas?


0 Kudos
1 Reply
Honored Contributor III

There's a separate forum about INDE.  Maybe this would get attention there.

0 Kudos