Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Kawajiri__Hayato
Beginner
520 Views

C++ comliper 18.0

I want use VS2017 to write OpenMP,but i find some instruction can't use. if the version of OpenMP is 2.0,too low.So I install the intel C++ compiler 18.0,and OpenMP 4.5 C/C++ supported in version 17.0,18.0 and 19.0 compiler,and intel c++ compiler can be used in VS2017.But when i use the OpenMP in compiler,i find the version of OpenMP is still 2.0.So,i really don't konw what should i do.

0 Kudos
4 Replies
GouthamK_Intel
Moderator
520 Views

Hi,

Thanks for reaching out to us!

You may need to set the intel c++ compiler with OpenMP support in the project properties. please follow the steps below:

 1)Set the compiler as Intel C++ in the project properties(you can select in the options after Right click on the project)

 2)Right-click on your project/source file: properties ->c/c++ -> language[intel c++ compiler] -> open MP support= Generate Parallel Code (/Qopenmp).

Please let us know if this resolves your issue.

Regards

Goutham

 

GouthamK_Intel
Moderator
520 Views

Hi,

Could you please let us know whether we can close this thread if your issue is resolved?

If your issue still persists, please do let us know. So that we will be able to help you resolve your issue. 

 

Thanks & Regards

Goutham

GouthamK_Intel
Moderator
520 Views

Hi,

Could you please let us know whether we can close this thread if your issue is resolved?

If your issue still persists, please do let us know. So that we will be able to help you resolve your issue. 

 

Thanks & Regards

Goutham

GouthamK_Intel
Moderator
520 Views

Hi,

We assume that the information provided by us helped you and your issue is resolved.

We are closing this thread. 

Feel free to raise a new thread in case of any further queries.

 

Have a good day!

 

 

Thanks & Regards

Goutham

 

Reply