Intel® C++ Compiler
Community support and assistance for creating C++ code that runs on platforms based on Intel® processors.

C++ software issue

Blake1
Beginner
599 Views

I have an app that uses both fortran and C++. I am currently using intel classic fortran compiler and I recently installed the base tool kit. I have two projects, one to build a static lib with the fortran code and then another to build all the C++ code and then use the fortran static library at link time. Everything works pretty well except the linker can't finish building the app because it can't find the main. Microsoft C++ doesn't use a main because it uses the MFC winmain object. The intel compiler doesn't seem to know anything about it. The problem started when I installed the base tool kit and intel sort of 'barged' in and started doing the C++ compiling itself. I need to find a way around this problem but I am not sure which way to go with it. I suppose I could completely uninstall intel oneapi base tool kit, but that seems pretty drastic. Is there some other way I could resolve this issue?

 

                   Blake M.

0 Kudos
3 Replies
ShanmukhS_Intel
Moderator
563 Views

Hi Scott,

 

Thanks for posting on Intel Communities.

 

We would like to request you to try giving the dependent libraries under below path of your application's properties page. Make sure you are changing the setting under appropriate platform(Win32/x64) of your application.

Step 1: In Visual Studio, At the top right corner, you could see Solution Explorer window. Kindly select it and click alt+enter to get into Configuration Properties page of your application.

Step 2: Select Configuration Properties -> Linker -> Input -> Additional Dependencies.

Step 3: Kindly try adding your dependent library path over here and check if this resolves your issue, if not kindly share us the debug log/project files as well, so that it helps us in analyzing the issue better.

Attaching the screenshot for your reference.

 

Could you please share us a sample reproducer and steps(if any) so that we could try reproducing the issue at our end and help you in resolving the issue.

 

Best Regards,

Shanmukh.SS

 

0 Kudos
ShanmukhS_Intel
Moderator
538 Views

Hi,


Reminder:

Is your issue resolved? Could you please share us a sample reproducer, so that we could try reproducing the issue at our end.


Best Regards,

Shanmukh.SS


0 Kudos
ShanmukhS_Intel
Moderator
509 Views

Hi,


We assume that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Best Regards,

Shanmukh.SS


0 Kudos
Reply