Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TRai2
Novice
118 Views

Cannot install icc/icpc/ifort

Some years ago, I'd been using Intel C++/Fortran compilers 8.1-10.0, but I took a break.

Wanting to use Intel C++/Fortran compilers, I downloaded composerxe-2011.0.084 and installed these rpms on my Gentoo Linux.

intel-parallel-studio-xe-022-1.0-0.noarch
intel-compilerpro-common-084-12.0-0.noarch
intel-compilerpro-vars-084-12.0-0.noarch
intel-compilerproc-common-084-12.0-0.noarch
intel-compilerprof-084-12.0-0.i486
intel-parallel-studio-xe-docs-022-1.0-0.noarch
intel-compilerprof-devel-084-12.0-0.i486
intel-compilerpro-devel-084-12.0-0.i486
intel-compilerproc-084-12.0-0.i486
intel-compilerproc-devel-084-12.0-0.i486
intel-compilerprof-common-084-12.0-0.noarch

Formerly (I mean C++ compiler 10.0), after editing iccvars.sh and icpcvars.sh, and setting environmental variables, I could use compilers, but this time the structure has been changed drastically.

I executed compilervars.sh and compilervars_arch.sh to set environment variables, and ran icc but in vain; I got errors:
-----------------------------------
tetsuji@maverick ~ $ icc
icc: error #10310: Failed to enable trusted storage check for licensing: WARNING: Enable Trusted Storage failed (flexnet error code 2). Trusted Storage based license could not be supported
-----------------------------------

I thought the environment variable INTEL_LICENSE_FILE isn't set correctly, but it's INTEL_LICENSE_FILE=/opt/intel/composerxe-2011.0.084/licenses:/opt/intel/licenses:/home/tetsuji/intel/licenses:/opt/intel/composerxe-2011.0.084/licenses:/opt/intel/licenses:/home/tetsuji/intel/licenses and the license file is in /opt/intel/licenses. (of course I checked the spelling of "licenses"). So I don't know what's wrong.

Will anyone help me? I feel like a newbie :(

Thank you in advance.

edit: I'm using the license file downloaded today.

0 Kudos
2 Replies
TRai2
Novice
118 Views

Self response.....

Sorry. My mistake. My license's permission was read protected to other users (rw----). Changing it with "chmod a+r", icc could be invoked.

Thank you very much!
JenniferJ
Moderator
118 Views

Please try followings:
1. set the INTEL_LICENSE_FILE to "/opt/intel/licenses" only.
$export INTEL_LICENSE_FILE=/opt/intel/licenses
2. try icc to see if it works

3.if not, delete any fileat "/usr/local/share/macrovision/storage/FLEXnet/INTEL*.data"
please make a backupof the file as"INTEL*.data.backup". this file is created by the flexnet.
4. try icc again.

Jennifer
Reply