Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
41 Views

Composer 2013.3.171 - internal error: 0_10711

Intel compiler composer 2013 , update 3 for Windows

With update 1 the same project worked fine.  

1>Compiling with Intel(R) C++ Compiler XE 13.1.1.171 [IA-32]... (Intel C++ Environment)
1>Rad_TERMA.C
1>C:\ALA711\sdlCAT3D\Rad_TERMA.C(81): (col. 5) remark: LOOP WAS VECTORIZED.
1>C:\ALA711\sdlCAT3D\Rad_TERMA.C(500): (col. 46) remark: FUSED LOOP WAS VECTORIZED.
1>Compiling with Intel(R) C++ Compiler XE 13.1.1.171 [IA-32]... (Intel C++ Environment)
1>radroi_auto.c
1>radmana.c
1>radfusi.c
1>": internal error: 0_10711
1>
1>Compiling with Intel(R) C++ Compiler XE 13.1.1.171 [IA-32]... (Intel C++ Environment)
1>RADTELE.C
1>Build log was saved at "file://C:ALA711\sdlCAT3D\CAT3D\CAT3D\Release\BuildLog.htm"
1>CAT3D - 0 error(s), 0 warning(s), 15 remark(s)
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

0 Kudos
8 Replies
Highlighted
Black Belt
41 Views

Update 3 appears to have more aggressive optimizations which are failing.  I submitted a case to premier.intel.com where I found it would compile with option /fp:source.  There is also a project file setting which should do it.  For what it's worth, they suggested /O1 as a safe level of optimization, or returning to an older working version.  If you want your case taken into account, I would suggest filing a bug report there or attaching the case here.

0 Kudos
Highlighted
41 Views

I was using update 1 to compile the same project, with sucess.  I really need maximum optimization level because some non-linear opt.  regions take minutes of execution.  Instead of returning to update 1 I will try with update 2.   

I am attaching radfusi.i   ,  the file which trigered the internal error.

0 Kudos
Highlighted
41 Views

 I  just remove update 3 and compile the project with update 2 , OK.

0 Kudos
Highlighted
Employee
41 Views

This issue has be resolved.  We will notify you when a compiler update containing the fix becomes available.

Thanks,
--mark

0 Kudos
Highlighted
Valued Contributor II
41 Views

Consider it as a workaround until an update with the fix is released: If the problem happens in some function you could disable optimizations just for that function with a #pragma optimize or #pragma intel optimization_level directives.
0 Kudos
Highlighted
Employee
41 Views

Armando,

I get several errors when compiling your .i file.  Could you please send the full compilation options you're using to compile the file. 

Thanks,
--mark

0 Kudos
Highlighted
41 Views

Dear Mark,   I am happy to know that you are working on that and the problem should be solved by now.  In the first place, I had to remove update 3 , because this is part of a big production project (CAT3D is Radiotherapy Planning System)  and we need to create customized updates for several customers every day.   Now the compiler is back on update 2, and it is working OK and the generated code is right as long as our regression test goes.

But the compilation options are identical, I did not touched that :;

/c /O3 /Ob2 /Oi /Ot /Oy /Qip /GA /D "WIN32" /D "NDEBUG" /D "_WINDOWS" /D "_CRT_SECURE_NO_WARNINGS" /D "_MBCS" /GF /MT /Zp1 /GS- /arch:SSE2 /fp:fast=2 /Zc:forScope- /GR- /Fo"Release/" /Fd"Release/vc90.pdb" /W3 /nologo /TC /Qopenmp /Qfp-speculation:fast /Qopt-matmul- /fp:double /Qstd=c99 /Qdiag-disable:1786,2557

On the other hand, there was no info of the region of code that triggered the internal error.  The only thing sure is that the internal error was emitted after opening  "radfusi.c" .  I am a compiler user (a physicist), not a compiler expert, but it is not clear to me how can you work with "radfusi.i"  because it is a rather big C99 project with some 50  .C files, severals .h  and lot of external (lib and dll) dependances.

If  I could be of help in any way let me know.

Thanks,

Armando

0 Kudos
Highlighted
41 Views

Update 4 solved the issue with my projects. I also made some other test and found no problems or improvements on the resulting code with update 4.

0 Kudos