Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Debugging problem

valerio19
Beginner
128 Views
Dear all,

I've just installed Parallel Studio and Cluster Toolkit.

When I use the Intel-C++ as compiler I'm not able to debug my application.

I set the debugging properties in the following way:

MPI CLUSTER DEBUGGER
- MPIRUN COMMAND: "C:\\Program Files\\Intel\\ict\\2011.0.014\\mpi\\ia32\\bin\\mpiexec.exe"
- MPISHIM Location: "C:\\Program Files\\Microsoft Visual Studio 8\\Common7\\IDE\\Remote Debugger\\x86\\mpishim.exe"
- MPIRUN ARGUMENTS: np -2 (two precessors)
- APPLICATION COMMAND: $(TargetPath)

When I launch the debugger I get the following error:
"Target for Debug Launch is not specified"

If I set the Remote Windows Debugger Properties it starts with a single processor

If I switch to VS-C++ compiler, it works correctly.

Could anyone help me?

Thanks in advance,

Valerio


0 Kudos
4 Replies
Dmitry_K_Intel2
Employee
128 Views
I was able to reproduce the error. It's not clear from the message what's incorrect in settings. Might be integration team may help. I'm moving this topic to C++ compiler forum.

Regards!
Dmitry
Sven_Prevrhal
Beginner
128 Views
First, Don't use macros such as $(TargetPath). When I used the absolute path to the debug executable, the error that you described went away and the debugger launched. However, it only launched ONE process not the number I had requested. That was with MPICH2, all in 64-bit. I wonder if Intel MPI would work. Is MPICH2 officially supported?
valerio19
Beginner
128 Views
Although I set "MPI CLUSTER DEBUGGER" as debugger to launch, the Visual Studio launches the "Remote Windows Debugger". Instead it works correctly when I set Visual C++ as compiler.
I'm using Intel MPI in 32 bit
patkins
Beginner
128 Views

Any update to this?

I am running Visual Studio 2008 and the 11.1.054 version of the C++ compiler and I run into this same problem.

I am using the 32-bit MPICH2 from ANL and I am following their instructions on setting up the debugger using their example code. Their instructions were:

# Re-install MPICH2 on your machine on a path (e.g.: C:\MPICH2) with no spaces

# Copy mpishim.exe to a directory without any spaces (e.g.: C:\MPICH2)

# Create a new VS project, hellow, in "c:\MPICH2\examples" directory and add the hellow.c source (https://svn.mcs.anl.gov/repos/mpi/mpich2/trunk/examples/hellow.c).

# Set the include/lib dep directories to point to MPICH2

# Compile the 32-bit/Debug configuration of the VS project

# Use the following settings,

Configuration: Active (Debug)

Platform: Active (Win32)

Debugger to launch: MPI Cluster Debugger

MPIRun Command: C:\MPICH2\bin\mpiexec.exe

MPIRun Arguments: -n 2

MPIRun Working Directory: C:\MPICH2\examples\hellow\Debug

Application Command:

Application Arguments:

MPIShim Location: C:\MPICH2\mpishim.exe

MPI network security mode: Accept connections from any address

MPI network filter:

Debugger type: Auto


So using this as my settings and the Visual Studio C++ compiler I can run the debug just fine. But if I use the Intel C++ compiler then I get the "Target for debug launch is not specified" error.
Reply