Community
cancel
Showing results for 
Search instead for 
Did you mean: 
tammo
Beginner
84 Views

Error : Intel C++ Compiler for Intel64 is not installed

Hi everyone,

I have a strange issue with the Intel C Compiler 11.1. I have the full professional edition for windows installed, along with microsoft visual studio 2008. However I cant compile for the x64 architecture (working on an x64 XP as well), because the message appears "File finding : Intel C++ Compiler for Intel64 is not installed".

I tried to reinstall, repair, remove reinstall everything, starting from Vis. Studio and the Compiler, but still no change. Even in the Visual Studio > Tools > Options > Intel C++ > Compilers menu I only see the Win32 Platform as being installed.

What can be wrong ? Of course, the ... \\Compiler\\bin\\...\\intel64 directory and the files are physically on the proper place.

Thx

0 Kudos
6 Replies
Hubert_H_Intel
Employee
84 Views

The x64 platform is not being installed by default in Microsoft Visual Studio* Professional. You need to start the installer again and check the 64-bit platform as described in the Intel Compiler release notes (ch. 2.1.1 'Configure Visual Studio for 64-bit Applications').

Then you need also the 64-bit version of the Intel C++ Compiler Professional. Have you used the 64-bit version of the Intel Compiler package (ends with _intel.exe, e.g. w_cproc_p_11.1.069_intel64.exe)or the full package (no suffix, e.g. w_cproc_p_11.1.069.exe)?

Regards, Hubert

tammo
Beginner
84 Views

Hi,

the x64 compiler options and tools for Vis studio 2008 were installed by default ... i didnt need to change this according to the release notes.

And among the Intel C++ Compiler Installation options (if I restart the installer and go to Add/Remove mode) I see "Intel C++ Compiler for applications running on Intel 64" as being already installed.

What else can be the reason ?

TimP
Black Belt
84 Views

Hubert is correct, VS2005 and 2008 don't install X64 support unless you check on both C++ and the X64 support inside C++. If Intel64 C++ were installed before that was present, it probably won't see the X64 linker automatically. modify VS to add X64 and repair of Intel C++ are likely steps to take.
JenniferJ
Moderator
84 Views

Your VS should have the x64 support otherwise you can't create the x64 configuration.

But didyou install the Intel C++ Compiler for IA32 and for Intel 64 separately?

In any case, try to uninstall (not repair) the Intel C++ Compiler and reinstall to see if it helps.

Jennifer

tammo
Beginner
84 Views

As I wrote, I checked, that x64 Compiler support was already installed in the Visual Studio 2008, and it IS installed now as well. I even tried to repair with Intel Compiler Installer, but still no change.

Is it known, from where the Visual Studio reads the information, which Intel Compilers are installed ? (registry entry, config file, whatever ?)

JenniferJ
Moderator
84 Views

As a safe method, I'd suggest to do following:

1. open tools -> Options dialog, goto "Intel C++ -> Compiler".

2. select "x64" for "Target Platform", then click "Reset all" button.

3. now try if the x64 compiler works.

Jennifer