Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Curtis_H_
Beginner
62 Views

Getting xilink: : error #10014 on a large VS Solution with /fast

I'm trying to get a very large Visual Studio 2013 solution to compile (100+ big projects).   All of the projects are being compiled with the /fast flag.  After waiting around 20-30 minutes for the solution to compile, the linker chokes with:

xilink: : error #10014: problem during multi-file optimization compilation (code 1)

I can see the RAM usage in Task Manager, increasing very quickly when linker starts running.  It runs up to +2gb, and then drops back to where it was before.  This is on a system running Windows 7 Pro 64 bit with 16gb of RAM and an Intel 3770.

I think I turned off the interprocedural optimizations with /Qip- and /Qipo-, so the complete flag listing is

/fast /Qpi- /Qipo-

Hopefully, that will let the solution compile and link (it's building right now).

Is there a way to let the linker use more RAM so the interprocedural optimization can be enabled?

0 Kudos
0 Replies
Reply