Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SergeyKostrov
Valued Contributor II
465 Views

How could I disable in a source file a Warning 673

How could I disable in a source filea Warning 673:


...
Warning #673: the initial sequence of preprocessing directives is not compatible with those of precompiled header file "Debug\\.pchi"
...

The same question is for Intel C++ compilerremarks...

Best regards,
Sergey

0 Kudos
16 Replies
Judith_W_Intel
Employee
465 Views


Not sure what version of the compiler or whether you are on Linux but the normal diagnostic disabling switch works for me.

sptxl8-403> icc -pch-use t.pch -c t.c
Warning #671: header files used to generate precompiled header file "t.pch" have changed

sptxl8-404> icc -pch-use t.pch -c -diag-disable 672 t.c
sptxl8-405>

SergeyKostrov
Valued Contributor II
465 Views

Judith, did you read my post carefully?

>>...How could I disable in a source filea Warning 673

Iunderlined that I want to disable that warning in a source file. It means, I can't disable that warning
with a #pragma warning ( disable : 673 ) directive, but I can disable it in a Visual Studio 2005 project.

OS: Windows XP 32-bit
IDE: Visual Studio 2005 SP1
C++ compiler: Intel C++Composer XE 2011 Update 9

I'll do another set of tests next week and I'll keep you informed.
Feilong_H_Intel
Employee
465 Views

Hi Sergey,

I did a quick experiment. I successfully disabled warning #1079 "return type of function `main` must be `int`"with #pragma warning(disable:1079). Could you please upload your test case, so that Judy and I could reproduce this problem?

Thanks,
Feilong
Judith_W_Intel
Employee
465 Views


ok, I think I understand what the problem is now. Sorry for not reading your original post carefully enough.

The #pragma warning ( disable : 673 ) is itself considered a preprocessing directive.

So if you add it (to either the source or header file) AFTER the preprocessed file has been created then
it will itself cause a the warning to be emitted (and the warning will be emitted when the preprocessing directive
is initiallyparsed so the warning has not yet been disabled).

So what I would suggest is you put the #pragma warning (disable: 673) at the top of the header file that you
are precompiling and/or at the top of the source filebefore you actually create the precompiled header. This seemed to solve the problem for me.

Judy
SergeyKostrov
Valued Contributor II
465 Views

Hi everybody,

Quoting Judith Ward (Intel)
...
The #pragma warning ( disable : 673 ) is itself considered a preprocessing directive.

So if you add it (to either the source or header file) AFTER the preprocessed file has been created then
it will itself cause a the warning to be emitted (and the warning will be emitted when the preprocessing directive is initiallyparsed so the warning has not yet been disabled).

[SergeyK] Thank you. I didn't know this.

So what I would suggest is you put the #pragma warning (disable: 673) at the top of the header file that
you are precompiling and/or at the top of the source filebefore you actually create the precompiled
header. This seemed to solve the problem for me.

[SergeyK] This is exactlywhat I've done and unfortunatelyit doesn't work.I'm simply overwhelmed
by a set of different issues but I will be able to continue attempts to solve it next week.

Best regards,
Sergey
SergeyKostrov
Valued Contributor II
465 Views

Could you please upload your test case, so that Judy and I could reproduce this problem?


Hi Feilong,

I'm currently integrating Intel C++ compiler with some project and I have lots of different issues similar to
'Warning 673' and because of this I'm unable to create a test case. Sorry about this and I'll keep you informed on my progress.

In overall, integration with the projectgoes well and Intel C++ compiler is the 5th supported compiler:

Microsoft C++ compiler - Done
MinGW C++ compiler - Done
Borland C++ compiler - Done
Turbo C++ compiler - Done
Intel C++ compiler - In progress

Best regards,
Sergey

SergeyKostrov
Valued Contributor II
465 Views

...So what I would suggest is you put the #pragma warning (disable: 673) at the top of the header file that you
are precompiling...

I've spent some timeagain and I believe that there is an issue / problem with the warning #673.

Here is some information:

------ Build started: Project: IccTestApp, Configuration: Debug Win32 ------

Compiling with Intel C++ Compiler XE 12.1.3.300 [IA-32]... (Intel C++ Environment)
Stdphf.cpp
...
Compiling with Intel C++ Compiler XE 12.1.3.300 [IA-32]... (Intel C++ Environment)
IccTestApp.cpp
...
Warning #673: the initial sequence of preprocessing directives is not compatible with those of precompiled header file "Debug\IccTestAppD.pchi"
...
Linking... (Intel C++ Environment)
xilink: executing 'link'
Creating library ...\Debug\IccTestAppD.lib and object ...\Debug\IccTestAppD.exp
Embedding manifest... (Microsoft VC++ Environment)
IccTestApp - 0 error(s), 0 warning(s), 1 remark(s)

========== Build: 1 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========

As you can see it is reported as a remark instead of asa warning.

Best regards,
Sergey

Feilong_H_Intel
Employee
465 Views

Sergey,

Sorry for the delay. I'm working with our developer to see what was wrong here.

Thanks,
Feilong
SergeyKostrov
Valued Contributor II
465 Views

...Sorry for the delay. I'm working with our developer to see what was wrong here...


Thank you for the update. Unfortunately, I can't provide a test case since I couldn't isolate a problem.

Best regards,
Sergey

Feilong_H_Intel
Employee
465 Views

Sergey,

Never mind. Our developer believes that this problem(showing 1remark rather than 1 warning)is caused by the capitalized "W" in "Warning #673". They are fixing it. The fix is expected in the next 13.0 beta update.

Thanks,
Feilong
SergeyKostrov
Valued Contributor II
465 Views

Thank you for the update, Feilong. However, I don't think that the problem is related to "...the capitalized W..."

Best regards,
Sergey
Feilong_H_Intel
Employee
465 Views

Sergey, 13.0 is released, and it contains the fix for the capitalized W issue. Please download it and try if the problem you reported still persists. Thanks, Felong
SergeyKostrov
Valued Contributor II
465 Views

>>...13.0 is released, and it contains the fix for the capitalized W issue. Please download it and try if the problem you reported still persists. Thank you. I'll verify it. Best regards, Sergey
Alexey_I_N_
Beginner
465 Views

I have problem with this too. Log here: icl -c -FIqt_gui_pch.h -Yuqt_gui_pch.h -Fptmp\obj\debug_shared\QtGuid_pch.pch /nologo /Zm200 /Qprec /Qipo /Zc:wchar_t- /Zi /Od /MDd /GS /W3 /MP /GR /EHsc -DQT_SHARED -DQT_THREAD_SUPPORT -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_BUILD_GUI_LIB -DQT_NO_USING_NAMESPACE -DQT_MAKEDLL -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -D_USE_MATH_DEFINES -DQT_NO_DIRECTDRAW -DQT_USE_BUNDLED_LIBPNG -DPNG_NO_ASSEMBLER_CODE -DQT_NO_CUPS -DQT_NO_LPR -DQT_NO_OPENTYPE -DQT_NO_STYLE_MAC -DQT_NO_STYLE_CDE -DQT_NO_STYLE_GTK -DQT_NO_STYLE_MOTIF -DQT_NO_STYLE_WINDOWSCE -DQT_NO_STYLE_WINDOWSMOBILE -DQT_NO_STYLE_S60 -DQT_NO_EGL -DQ_INTERNAL_QAPP_SRC -DQT_NO_DIRECTWRITE -DQT_DLL -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -I"..\..\include\QtCore" -I"..\..\include" -I"..\..\include\QtGui" -I"tmp\rcc\debug_shared" -I"tmp" -I"..\3rdparty\wintab" -I"image" -I"..\3rdparty\libpng" -I"..\3rdparty\zlib" -I"..\3rdparty\zlib" -I"..\3rdparty\harfbuzz\src" -I"dialogs" -I"..\..\include\ActiveQt" -I"tmp\moc\debug_shared" -I"." -I"..\..\mkspecs\win32-icc" -Fotmp\obj\debug_shared\ @C:\Users\krab\AppData\Local\Temp\qlistwidget.obj.7840.163286.jom qlistwidget.cpp Warning #673: the initial sequence of preprocessing directives is not compatible with those of precompiled header file "tmp\obj\debug_shared\QtGuid_pch.pchi"
Feilong_H_Intel
Employee
465 Views

Hi, Did you guys try icl compiler in Composer XE 2013 update 1? If the problem still persists, I'd love to get a test case from you. Thanks, Feilong
SergeyKostrov
Valued Contributor II
465 Views

Hi Fellong, I already stated in one of my posts that '...Unfortunately, I can't provide a test case...'. There are too many dependencies between source files. Best regards, Sergey
Reply