Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Gaiger_Chen
New Contributor I
49 Views

How should I do to set dll path in VS?

Hi

I would like to use OpenCV dll in my program.

When I use native compiler in VC, that is regular at all.

but when I switch to use icc, the is said, could not load cx210.dll.

Ok, it is dll path set wrong.

But what I tried, that is always invalid.

I know there is a solution : copy/move dlls of opencv which i would use into the project folder.

But it is too unwise.

Is anyone know how to fix the error by setting project/VS?

thank you.

ps: I use icc 10.1 with vs 2005, and CHINESE windows XP SP3.

(I do know if the font encoding make this, as Vtune )






0 Kudos
1 Reply
JenniferJ
Moderator
49 Views

Try the following:
1. turn-off the /nologo for linker so you can see the full link options used - is the Opencv-dir showed as a link lib option?
2. you can add the extra-lib-dir under Project Property -> Linker -> General tab, "Additional Library Directories"

If this does not work, please attach the build log.
Another place to add is under menu "Tools -> Options -> Projects and Solutions -> VC++ Directories", "Libraries"

Reply