Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Marián__VooDooMan__M
New Contributor II
108 Views

ICC xe 2015 + MSVC 2013: GUI: "compiler optimization report" tab is empty

Greetings,

I have 2 projects in my solution, but when I press F7 to build, new "compiler optimization report" tab is empty window with only header line.

Any suggestions?

0 Kudos
10 Replies
Marián__VooDooMan__M
New Contributor II
108 Views

ping?

Marián__VooDooMan__M
New Contributor II
108 Views

ping again?

MalReddy_Y_Intel
Employee
108 Views

Hi,

Sorry for late reply, I could able to get the optimization report with ICC xe 2015 + MSVC 2013 on GUI.

For example, I have selected properties->c/c++->Diagnostics[Intel C++]->optimization diagnostic phase->All optimization phases for some test project and got the below report.

Are you looking for any specific optimization report ?

Opt_report_icc15.0.png

 

Marián__VooDooMan__M
New Contributor II
108 Views

Greetings,

I have setting ->

Optimization diagnostic phase ==All optimization phases

it is default option, not displayed as a border letter type (i.e. default setting);

MalReddy_Y_Intel
Employee
108 Views

Please check in the below path if you are able to invoke the new "Compiler Optimization Report" window.

#View > Other Windows in VS2013.

Thanks,

Reddy

 

Marián__VooDooMan__M
New Contributor II
108 Views

Greetings,

Please could you be more specific, and guide me how to enable it?

PS: MSVC 2013

Best

MalReddy_Y_Intel
Employee
108 Views

Hi,

Open project with MS visual studio 2013--->

           Go to view->other windows->compiler optimization report.

Reddy

 

Marián__VooDooMan__M
New Contributor II
108 Views

Hello,

I had this window, but it was empty (only header line was shown).

I had to re-install my laptop for some other issue, and now that window contains ICC's optimization report.

But in the solution there I have 2 projects, and when I build them both, only messages from first project are reported in the window.

Any suggestions?

TIA!

Marián__VooDooMan__M
New Contributor II
108 Views

I think I forgot to set "optimization diagnostic level" to 5 (the highest possible value).

I will post report whether I was successful, but since the project is large and is using many statically linked libraries, it will take some time.

Marián__VooDooMan__M
New Contributor II
108 Views

Marián "VooDooMan" Meravý wrote:

I think I forgot to set "optimization diagnostic level" to 5 (the highest possible value).

Yes, that did the trick!

Reply