Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Petros_M_
Beginner
145 Views

ICInstallDir

In my installation of PSXE 2017 (basic, i.e. no update) (win7, 64bit on VS2010, 2013, 2015) one sees 2 directories, namely:

a)C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017\windows

and

b) C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows

a) is effectively empty: it contains a redist folder, which in turn contains 2 emty folders (intel64_win and intel32_win(.

b) Contains a bin folder, containing a bunch of batch files and a number of folders which are architecture specific and each one contains the icl and xilink applications. Also, in b) there are folders for compiler, daal, ipp, mkl, redist, tbb.

When in VS2015 I select the Intel C++ 17.0 toolset, I see: ICInstallDir pointing to a). As a result, I cannot use it !

Can you please help me resolving this?

TIA,

Petros

PS1: Interestingly enough when I start the "Intel Compiler 17.0 Intel(R) 64 Visual STudio 2015" command prompt, I see:

C:\Program Files (x86)\IntelSWTools>echo %ICInstallDir%
C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows

(i.e. the correct one !)

PS: One possible(?) remedy would be to somehow overwrite the ICInstallDir  project macro. However, by looking at some intel props files, it is not to be found where (naively, at least) these files look for in the registry - provided I am looking at the right places ;-)

 

 

0 Kudos
2 Replies
JenniferJ
Moderator
145 Views

the a) folder contains links to the latest installed compiler.

>> When in VS2015 I select the Intel C++ 17.0 toolset, I see: ICInstallDir pointing to a). As a result, I cannot use it !

did you try to build a chelloworld to see if it builds? it should. otherwise, it's a bug.

to set the project or file to use Intel C, right click on the project or file, select "Intel Compiler > Use Intel C++ Compiler". then build the project.

Jennifer

Petros_M_
Beginner
145 Views

Hi Jennifer,

Of course I tried a Hello world program. And I got the same error.

And -of course- I know how to activate the Intel compiler.

By now - 3 (three!!!!) weeks later- the problem has been taken by one of intel's engineers (Markus) who has been trying to work with the engineers to arrive at some workaround.

For the benefit of others that might encounter the same issue, let me say here that, it seems that the problem stems from the installation scripts attempting to create symbolic links, in order to resolve the version to be used.

However, to be able to do this on windows, one has to have enhanced admin access privileges, which come very rare to have in a corporate environment.

Please -for those interested- keep in mind that, this is still a hypothesis -albeit very likely, which has not been confirmed as: a) the Intel engineers have not been able yet, to come up with a workaround,  and b) I have not been able to locate an admin, with this kind of access privileges in my company, yet.

Thank you for the effort to help,

Al the best, Petros

Reply