Community
cancel
Showing results for 
Search instead for 
Did you mean: 
gilrgrgmail_com
Beginner
283 Views

Icl recompiles project whenever a single file is changed.

Iam compiling aproject with hundredc++ files.Whenever I change a c++/h file the whole project the intel compiler recompiles the whole project.
I use:
Intel C++ Composer XE 2011 Integration for Microsoft Visual Studio* 2010, Version 12.0.1029.2010.

I toggled to m$ compiler and it compiles only the relevant files.

0 Kudos
42 Replies
Feilong_H_Intel
Employee
181 Views

Hi there,

I tried with a small project in VS2010& Intel C++ Composer XE 2011 update 4 (integration version 12.0.1029.2010). Unfortuantely, I can't reproduce the problem. Could you please upload a small test case for me?

Thank you.
--
Feilong H.
Intel Developer Support

Tools Knowledge Base: http://software.intel.com/en-us/articles/tools
gilrgrgmail_com
Beginner
181 Views

I attached a zip file of a c++ project.
Notice that even a minor change in one of the 3 classes causes recomilation of the other 2 classes..
Gadi_Zadikoff
Beginner
181 Views

I have the exact same problem, I can also reproduce the rebuild with the sample project above
Feilong_H_Intel
Employee
181 Views

Hi gilrgrgmail.com & Gadi,

Could you please upload the file "icl.read.1.tlog"? It seems this files tracks the file names which need to be re-compiled.

Thanks,
Feilong
gilgil
Beginner
181 Views

I have the same problem.
The file you have mentiones exist yet is empty.
Feilong_H_Intel
Employee
181 Views

Thank you guys. A developer in our IDE integration team is looking into this issue now. He needs to reproduce it in his system first. I'llyou know once I have an update.

Thanks,
Feilong
msolus
Beginner
181 Views

I am also experiencing this problem, usingC++ Composer Update 5. I would like to stress that the issue is only present when targeting x64. I attach a simple solution having just two cpp filesand the corresponding icl.read.1.tlog files generated during 32 and 64 bit compilation. As you can see, this file is empty when the target is 64 bit.
Do you have any update ona possible fix, Feilong? I am evaluating C++ Composer and thinking of getting a student license, butafter a couple of weeks of testingI have already found two annoying bugs.
gilgil
Beginner
181 Views

Any news regarding this bug ?
It costs me with very long compilation time and causes massive time loss..
Feilong_H_Intel
Employee
181 Views

Hi,

We reproduced this problem on one machine. Engineering team is investigating this issue. I'll keep you posted with any status update.

Thanks,
Feilong
JenniferJ
Moderator
181 Views

Hi msolus,
do you have VS2010 SP1 installed?

From the log file it seems thatyou have Intel C++ Composer XE update5 installed.do you also have Intel Parallel Composer 2011 or Intel Parallel Studio 2011 installed too?

thanks,
Jennifer
msolus
Beginner
181 Views

Dear Jennifer,
I think Ihave not installedVS2010 SP1 yet. I attach you a picture reporting the version of VS2010 and the Intel products.
I installed Parallel Studio XE 2011 update 2 and then C++ Composer XE 2011 update 5 (which I believe is a more recent version than the one included in Parallel Studio XE 2011).
msolus
Beginner
181 Views

I installed VS2010 SP1 but this does not fix the issue. By the way, using the Visual C++ compilereverything works as expected, both in VS2010 and in VS2010 SP1.
Sukruth_H_Intel
Employee
181 Views

Hi gilgil,
If you are using VS2010 then you can check out this option:-

In VS2010 -->Tools / Options / Projects and Solutions / Build and Run
and then
choose "On run, when projects are out of date: Never build".

Then, manually build the project only where sourcecode has been edited and finally run the startup project.

Hope it will be helpful.

Thanks and Regards,
Sukruth.H.V


gilgil
Beginner
181 Views

The problem occures both with the sp1 and without it.
As so, the problem remains usingthe last build of intel composer.
llne
Beginner
181 Views

I have this exact same problem. Turning on higher build verbosity (Tools:Build and Run:MSBuild Project output verbosity -> Detailed) shows that msbuild thinks the files need to be rebuilt because they aren't found in the last tlog. But the tlog is empty. I've noticed this for all of my Intel projects in VS2010. The read and write tlogs are always empty. When using cl this is not a problem, the files are filled normally as the build progresses, but not with icl.

Who is responsible for updating the tlog, msbuild or icl?

Any ideas?
gilgil
Beginner
181 Views

there are 2 (probably) related issues:
1. when performing rebuild icl uses all cores. yet the "unwanted" rebuild uses single core and thread - thus significantly slower than a rebuild.
2. the "unwanted" rebuildproduce many time code with bugs. when perfroming rebuild the code runs correct.

gilgil
Beginner
181 Views

Hi Sukruth.
I have tried the method you suggested - the problem remains.
Feilong_H_Intel
Employee
181 Views

Hi all,

Engineering made some progress and probably identified root cause. I'll let you know when I have more update for you.

Thanks,
Feilong

Feilong_H_Intel
Employee
181 Views

Hi all,

The problem is caused by MS security update patches. As a temporary workaround, please uninstall KB2507938 if SP1 is not installed and uninstall KB2567680 if your Windows has SP1. Engineering is working on a fix for this issue.

Please let me knowwhether this workaround works for you or not.

Thanks,
Feilong
VADIM_G_Intel
Employee
104 Views

And don't forget to reboot your computer after you uninstalled the updates mentioned above. Otherwise the patch will continue affecting build.
Reply