Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.

Incremental compilation not working

dnesteruk
Beginner
264 Views

I have a VS2013 solution with a couple of CPP/H files as well as a precompiled header which contains a lot: it has references to Boost, Intel libraries and more. My precompiled header is set up correctly on all files: it's set to Create on stdafx and Use on other files.

Now the problem I have is that, every time I go to Build Project, the entire thing gets built, using the precompiled header and all. This is not right, because stdafx.cpp should only be built once. And this problem is Parallel-XE-specific because Microsoft does it correctly.

0 Kudos
3 Replies
Shenghong_G_Intel
264 Views

You may take a look at below link regarding the differences of Intel compiler precompiled header support and see whether you hit one the cases.

https://software.intel.com/en-us/node/522754

Thanks,

Shenghong

dnesteruk
Beginner
264 Views

shenghong-geng (Intel) wrote:

You may take a look at below link regarding the differences of Intel compiler precompiled header support and see whether you hit one the cases.

https://software.intel.com/en-us/node/522754

Thanks,

Shenghong

Umm, no, I'm not hitting any of these cases and my problem is more fundamental: not so much with the generation of PCH but the fact it gets regenerated on every compile, even if I change a single symbol in one of the CPP files. This shouldn't be happening.

Feilong_H_Intel
Employee
264 Views

Hi dnesteruk,

Are you able to create a smaller test case (solution) that demostrates the problem?  We need something to reproduce it on our machine and then investigate.

Thanks.

Reply