Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
21 Views

Installing C++ with existing VS2005 and Intel Fortran compiler

I installed the Intel Fortran compiler V11.0 along with Visual Studio 2005 on a Windows XP 32 bit Dell computer. That works. Now I tried to install the Intel C++ compiler V11.0 using both the standard install and the custom install and the installer gives me an error saying that my system does not have Visual Studio and tells me to install VS before installing C++. Of course it does have Visual Studio 2005. How do I get the installer to recognize that I have VS 2005 so that I can install C++ and use VS for mixed language development?
0 Kudos
5 Replies
Highlighted
Moderator
21 Views

what edition of VS2005 do you have? is it express edition?

Jennifer

0 Kudos
Highlighted
Black Belt
21 Views

what edition of VS2005 do you have? is it express edition?


Or possibly, the PPE subset of VS2005 which ifort will install when it doesn't find a standard Visual Studio? PPE doesn't support C++. PPE would have to be removed and replaced with a VS from Microsoft, which includes MSVC.
VS Express doesn't support GUI integration with ifort or ICL, and is likely to require text editing to set up for command line operation.

0 Kudos
Highlighted
Beginner
21 Views

Quoting - tim18
Or possibly, the PPE subset of VS2005 which ifort will install when it doesn't find a standard Visual Studio? PPE doesn't support C++. PPE would have to be removed and replaced with a VS from Microsoft, which includes MSVC.
VS Express doesn't support GUI integration with ifort or ICL, and is likely to require text editing to set up for command line operation.

I installed the version of VS 2005 that came in the download file with the Fortran v.11 compiler. This had a name like Preferred Partners or something. Is that PPE? I don't know what PPE means. Sorry for being so uninformed.
0 Kudos
Highlighted
Employee
21 Views


The PPE is Premier Partner Edition. This is packaged with some versions of Fortran compiler compiler and can only be used with Fortran compiler only. You can not usePPE version of VS2005 with Intel C++ compiler.
0 Kudos
Highlighted
Employee
21 Views


Is this resolved?
0 Kudos