Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
15 Views

Installing Intel C++/Fortran Compiler on Cent OS 5.5 64 Bit

Hi

When i'm installing Intel C++/Fortran compiler on Cent Operating System 5.5 version - 64 bits that the error problem is given below:

****************************************** error ***************************************************

---------------------------------------------------------------------------------------------------------------------------------------------------------------------
There is one or more optional unresolved issues. It is highly recommended to fix
it all before you continue the installation. You can fix it without exiting from
the installation and re-check. Or you can quit from the installation, fix it and
run the installation again.
--------------------------------------------------------------------------------
Missing optional pre-requisite
-- cannot determine operating system type
-- system glibc or kernel version not supported or not detectable
1. Skip missing optional pre-requisites [default]
2. Show the detailed info about issue(s)
3. Re-check the pre-requisites

h. Help
b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [1]:


-------------------------------------------------------------------------------------------------------------------------------------

Cannot determine which operating system is running. Supported operating systems
for this release include:
- Asianux* 3.0
- Debian* 5
- Fedora* 10 (IA-32 and Intel 64 only)
- Red Hat Enterprise Linux* 3, 4, 5
- SGI ProPack* 5 (IA-64 and Intel 64 only)
- SuSE Linux* Enterprise Server* 9, 10, 11
- Turbo Linux* 11
- Ubuntu* 9.04
--------------------------------------------------------------------------------
1. See next issue [default]
2. Back to Pre-requisite summary dialog

h. Help
b. Back to the previous menu
q. Quit

---------------------------------------------------------------------------------

System glibc or kernel version not supported or not detectable.
Supported glibc/kernel versions:
architecture kernel glibc
IA-32 2.4 2.2.93, 2.3.2
IA-32 2.6 2.3, 2.4, 2.5, 2.6
IA-64 2.4 2.3.2
IA-64 2.6 2.3, 2.4
Intel 64 2.4 2.3.2
Intel 64 2.6 2.3, 2.4, 2.5, 2.6
--------------------------------------------------------------------------------
1. Finish with prerequisites and continue installation [default]
2. Back to Pre-requisite summary dialog

h. Help
b. Back to the previous menu
q. Quit

********************************** end of the error *****************************************



In my system, the operating system, kernel and glibc version is given below:

Operating System release information :-
------------------------------------------------------------------

LSB Version: :core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID: CentOS
Description: CentOS release 5.5 (Final)
Release: 5.5
Codename: Final

output of the uname -a :
---------------------------------------
Linux volga 2.6.18-194.el5 #1 SMP Fri Apr 2 14:58:14 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

kernel package version information :-
--------------------------------------------------------------
kernel.x86_64 2.6.18-194.el5 installed
kernel-debug.x86_64 2.6.18-194.el5 installed
kernel-debug-devel.x86_64 2.6.18-194.el5 installed
kernel-devel.x86_64 2.6.18-194.el5 installed
kernel-doc.noarch 2.6.18-194.el5 installed
kernel-headers.x86_64 2.6.18-194.el5 installed
kerneloops.x86_64 0.11-1.el5.rf installed

glibc package version information :-
-----------------------------------------------------------
compat-glibc.i386 1:2.3.4-2.26 installed
compat-glibc.x86_64 1:2.3.4-2.26 installed
compat-glibc-headers.x86_64 1:2.3.4-2.26 installed
glibc.i686 2.5-49 installed
glibc.x86_64 2.5-49 installed
glibc-common.x86_64 2.5-49 installed
glibc-devel.i386 2.5-49 installed
glibc-devel.x86_64 2.5-49 installed
glibc-headers.x86_64 2.5-49 installed
glibc-utils.x86_64 2.5-49 installed

Can you tell me what is the correct solution? I'm using Cent OS 5.5 - 64 Bits only but i don't want to install other
operating system.

Thanks in advance,
Ashok



0 Kudos
3 Replies
Highlighted
Black Belt
15 Views

It does look like a bug in detection. A bug report would have to include the version of ifort or icc you are installing, and the g++ which is active (did you install that?). Evidently, the latest ifort/icc versions (11.1.073) may have been tested on more recent releases of Red Hat. CentOS is close enough to the corresponding Red Hat that it's a fair bet that if you accept the unsupported installation, you will be able to run successfully. If you got a further complaint about JRE version, you might have to tinker with adding Sun JRE in order to run the GUI debugger idb.
0 Kudos
Highlighted
Employee
15 Views

I agree with Tim. Please make sure that you have GNU gcc development environment installed. You should skip the pre-requisite checking and install the compiler. It should work.

Let us know if it our suggestion helped you.
0 Kudos
Highlighted
Moderator
15 Views

also see this thread for fyi: http://software.intel.com/en-us/forums/showthread.php?t=69054

Jennifer
0 Kudos