Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
12 Views

Integration of XE 2016 Beta into Visual Studio 2015 Community RC

After installing the XE 2016 beta, Visual Studio 2015 Community RC fails to load properly.  In the log the following issue is reported:

Could not load file or assembly 'Intel.Misc.Utilities, Version=15.0.14.0, Culture=neutral, PublicKeyToken=f4875dd4c8d7762f' or one of its dependencies. The system cannot find the file specified.

I tried to raise this as an issue in Intel premier support but I could not get past step 1 as I was unable to enter a product that it recognised and the search never returned anything.  Since I could not get past step 1, I was unable to report the issue so I am raising it here instead.

  with my regards,  Brian Gladman

 

 

0 Kudos
11 Replies
Highlighted
12 Views

Hi Brian,

Thank you for your problem report.  I'm entering this issue to our problem-tracking database.  Our integration team will look into it further.

Thanks.

0 Kudos
Highlighted
12 Views

Hi Brian,

Engineering team replied that a similar issue occurred in early versions of 2016 beta, and it has been fixed.  Are you using 2016 beta Update 1?  If no, please upgrade to Update 1.  In case that the problem still persists in beta Update 1, please go to Visual Studio Help menu -> About Microsoft Visual Studio, and click on Intel Parallel Studio XE 2016.  Then upload a screenshot.  See the following screenshot, which is what I have on my machine.  We need the version numbers in red circles.

Thanks.

HelpAbout1.png

0 Kudos
Highlighted
Beginner
12 Views

It is the beta1 versiojn that I have installed. Here is the screenshot you requested.

    regards, Brian

 

0 Kudos
Highlighted
Black Belt
12 Views

I'm getting many messages about rolling back failed components in my attempt to add VS2015 integration to the beta update 1 installation.  It seems to say I must delete the entire psxe installation and start over, after breaking it.  I ran a repair phase following modify and it came up with no compiler installed.

I think we were warned sufficiently that this wouldn't work until some time this summer that it doesn't warrant a formal problem report.

I didn't have such difficulty with the 2015 update 4 (modify and repair steps both required), but that installation leaves stuff to be desired, like having to open separate windows to use CL or ICL, and the messages about dropping back from -Zi to -Z7 on account of not seeing the mspdb140.dll.  Would those be subject for problem report on premier?  Looks like XE2015 integration is doing something wrong with PATH settings.

It hardly seems worth the 8 hours required to install VS2015 with no options.  I won't ask if the Android features in VS2015 are relevant to Intel since the stores stopped carrying Intel Android products, but they did replace my Android handset with the Intel CPU and failed microphone.

0 Kudos
Highlighted
12 Views

Engineering team replied that this integration issue has been addressed in the upcoming beta update.  The update will be posted to web soon.

Thanks.

0 Kudos
Highlighted
Beginner
12 Views

Many thanks for resolving this issue. 

       best regards, Brian

 

0 Kudos
Highlighted
12 Views

Brian,

Beta update 2 has been posted to web.  You may download it now.  FYI.

Thanks.

0 Kudos
Highlighted
Beginner
12 Views

Thanks for your work on this. I have installed the beta update 2 and I can confirm that it installs perfectly.

      best regards, Brian

0 Kudos
Highlighted
Black Belt
12 Views

Yes, yesterday's update resolved the installation problems.

What it didn't fix, for my testing of Advisor:

 Advisor doesn't work on Windows 10, as it fails to set permissions when creating result folders.  Other tools are fine on win10.

If functions are compiled by different Intel compilers, even within the supported range, Advisor log filtering isn't enabled.  Everything has to be compiled by the same 15.0 or 16.0 compiler release.

0 Kudos
Highlighted
Employee
12 Views

Windows 10 is not supported in Advisor XE yet, it will be enabled in future releases.

0 Kudos
Highlighted
Beginner
12 Views

Attempting to use Visual FORTRAN to recompile some software.

I am getting a linker error.

Severity    Code    Description    Project    File    Line    Suppression State
Error        error PRJ0019: A tool returned an error code from "Performing Custom Build Step..."        Project        
Error        fatal error LNK1171: unable to load mspdb140.dll (error code: 193)        LINK        

Anyone know how to solve this for

parallel_studio_xe_2016.1.051

Thanks.

 

0 Kudos