Community
cancel
Showing results for 
Search instead for 
Did you mean: 
fevrier
Beginner
204 Views

Intel Compiler and zsh

Jump to solution

Hello,

I installed the Intel Compiler (icpc) 14.0.1 on Ubuntu 12.04 LTS. I'm using zsh. I included the folliwing lines to the file .zshrc:

source /opt/intel/bin/compilervars.sh intel64
export MKL_DYNAMIC=false
export MKL_NUM_THREADS=16

But each time I open a new terminal, I've got the following error:

/opt/intel/composer_xe_2013_sp1/tbb/bin/tbbvars.sh:45: = not found

How can I fix it?

Thanks,

Clèm

0 Kudos
1 Solution
fevrier
Beginner
204 Views

I found a solution. Line 45 of the file
/opt/intel/composer_xe_2013_sp1/tbb/bin/tbbvars.sh

Change:

if [ $? == 0  ]; then

this way:

if [ $? '==' 0  ]; then

Clèm

View solution in original post

7 Replies
fevrier
Beginner
205 Views

I found a solution. Line 45 of the file
/opt/intel/composer_xe_2013_sp1/tbb/bin/tbbvars.sh

Change:

if [ $? == 0  ]; then

this way:

if [ $? '==' 0  ]; then

Clèm

View solution in original post

SergeyKostrov
Valued Contributor II
204 Views
I wonder if Intel C++ compiler software engineers could review all bat or sh files for all supported platforms and configurations because sometimes they do not set a proper environment for the compiler. For example, take a look at a bat file for a 64-bit Intel C++ compiler with Visual Studio 2010 integration ( it doesn't set environment at all ).
204 Views

try to change “if [ $? == 0 ]; then” to “if [[ $? == 0 ]]; then” in that line.

we are going to fix this.
--Vladimir

204 Views

Sergey Kostrov wrote:

For example, take a look at a bat file for a 64-bit Intel C++ compiler with Visual Studio 2010 integration ( it doesn't set environment at all ).

hello, where is this bat file? regular file sets the environment successfully:

C:\Program Files (x86)\Intel\Composer XE 2013 SP1\bin>iclvars.bat intel64 vs2010

Intel(R) Parallel Studio XE 2013 SP1
Copyright (C) 1985-2013 Intel Corporation. All rights reserved.
Intel(R) Composer XE 2013 SP1 Update 1 (package 139)
Setting environment for using Microsoft Visual Studio 2010 x64 tools.


C:\Program Files (x86)\Intel\Composer XE 2013 SP1\bin>icl
Intel(R) C++ Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 14.0.1.139 Build 20131008
Copyright (C) 1985-2013 Intel Corporation.  All rights reserved.

icl: command line error: no files specified; for help type "icl /help"

SergeyKostrov
Valued Contributor II
204 Views
Hi Vladimir, I'll post all technical details some time later. Thanks.
SergeyKostrov
Valued Contributor II
204 Views
I just realized that you're using latest version of Intel C++ compiler, and I'm not. So, I'll let you know what needs to be verified since I see on your computer Environment Setup is working.
SergeyKostrov
Valued Contributor II
204 Views
Vladimir, Please review these three cases: Case #1: [Works] - C:\Windows\SysWOW64\cmd.exe /E:ON /V:ON /K ""C:\WorkLib\ICC2013\Composer XE 2013\bin\ipsxe-comp-vars.bat" intel64 vs2008" Case #2: [Doesn't work] - C:\Windows\SysWOW64\cmd.exe /E:ON /V:ON /K ""C:\WorkLib\ICC2013\Composer XE 2013\bin\ipsxe-comp-vars.bat" intel64 vs2010" Case #3: [Doesn't work] - C:\Windows\SysWOW64\cmd.exe /E:ON /K ""C:\Program Files (x86)\Common Files\Intel\Parallel Studio XE 2013\ipsxe-vars.cmd" ia32_intel64 vs2010" Note: I also won't be surprised if [Doesn't work] cases are already fixed. Thanks in advance.
Reply