Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Martin_F_
Beginner
86 Views

Intel(R) Threading Blocks 4.2 update 5 for OS X* installation issue

After Installation icc throws a warning: ld: warning: directory not found for option '-L/opt/intel/composer_xe_2013_sp1.3.168/compiler/lib'

I created an empty directory. Now the message is gone. Is this the correct way to handle this?

0 Kudos
9 Replies
Feilong_H_Intel
Employee
86 Views

Hi Martin,

It appears that we don't have stand-alone TBB installer for OS X.  It is a component of Composer XE 2013 SP1.  You may download Composer XE 2013 SP1 Update 3 from IRC.  Its default installation directory is /opt/intel/composer_xe_2013_sp1.3.166, not /opt/intel/composer_xe_2013_sp1.3.168.

Thanks

86 Views

Hello, 

we do have standalone Intel TBB installer for OS X. Martin, it would be good if you submit an issue to the premier support. I'll ask our support team to look at this.

Feilong, you can get in touch with me if you need more info. /opt/intel/composer_xe_2013_sp1.3.168 is folder for Intel(R) Threading Blocks 4.2 update 5. /opt/intel/composer_xe_2013_sp1.3.166 is folder for update 4 of Intel TBB (and Composer XE 2013 SP1 update 3)

--Vladimir

Giorgio_L_
Beginner
86 Views

Hello

I have the same  problem and (more or less) the same problem with the previus up date.

(see may post in the middle of november 2013 and the solution).

Maybe .........

Giorgio

 

Martin_F_
Beginner
86 Views

Thank you, Giorgio,

I tried that and first, it did not work.

Then I changed the PROD_DIR in /opt/intel/composer_xe_2013_sp1.3.168/bin/compilervars.sh to /opt/intel/composer_xe_2013_sp1.3.166

Now the message is gone. Hope, I got it right now.

Giorgio_L_
Beginner
86 Views

Hello Martin!

Maybe the question is naive but "where" you've changed the PROD_DIR

Giorgio

 

 

Martin_F_
Beginner
86 Views

In the file /opt/intel/composer_xe_2013_sp1.3.168/bin/compilervars.sh line 10

Giorgio_L_
Beginner
86 Views

 

Hello Martin!

I corrected the file sh but the message remains.
However, aside from the annoying message it seems that everything works.

Giorgio

Martin_F_
Beginner
86 Views

Do you have "source /opt/intel/bin/compilervars.sh intel64" in your .profle?

Giorgio_L_
Beginner
86 Views

yes I have

Reply