Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jeff_Hensley
Beginner
31 Views

License problem ... why is it trying to hit the internet

I have the Professional version of the C++ compiler (11.1.067) and for months it has worked wonderfully on my Mac Pro. This week, something has changed. There is a terrible lag at the beginning of any call to the compiler(s). There seems to be a 10-15 second delay before anything happens. For example, even "icc -help" takes >10 seconds to return.

After fiddling around and ruling out hardware issues, I discovered that if I unplug the ethernet cable then the compilation begins immediately. The only conclusion I can come up with is that for some reason it is looking externally for the license and then times out and goes ahead and uses the local license.

Which makes no sense to me, because this is a single-user, uncounted license. Why would there be any attempt to hit the internet? And I didn't upgrade the OS or anything that should have had any effect...

Anyone have any insights?




0 Kudos
3 Replies
JenniferJ
Moderator
31 Views

Did you install any other software that uses FlexLM license?

There're two env-var that might affect this:
LM_LICENSE_FILE
INTEL_LICENSE_FILE

If you have both set, the icc driver will look through all the possible directories for valid license till finding one.

Jennifer

Jeff_Hensley
Beginner
31 Views

Did you install any other software that uses FlexLM license?

There're two env-var that might affect this:
LM_LICENSE_FILE
INTEL_LICENSE_FILE

If you have both set, the icc driver will look through all the possible directories for valid license till finding one.

Jennifer


Aha! Thanks Jennifer, that was the missing piece that I needed! Indeed, LM_LICENSE_FILE is set to get a FlexLM license for a debugger. Looks like the machine that has our license server is down, and that is causing the problem...

Now, is there some way that I can still set LM_LICENSE_FILE for the debugger, but not get Intel products to go looking there?

Many, many thanks!

JenniferJ
Moderator
31 Views

Quoting - Jeff Hensley
Now, is there some way that I can still set LM_LICENSE_FILE for the debugger, but not get Intel products to go looking there?
No, as of right now, there's no method to disable the compiler not checking LM_LICENSE_FILE.

But I've got the accurate information. The intel compiler checks the license in the following order:
1. INTEL_LICENSE_FILE
2. LM_LICENSE_FILE
3. the current directory of the icl or icc

So in your case, is INTEL_LICENSE_FILE points to the correct license? If not, please correct it and see if the license checking will be faster.

Thanks,
Jennifer