Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Arne_Lkketangen
Beginner
57 Views

Linker error

Dear All,

I have been using Microsft Visual Studio for many years, with Microsofts C++ compiler.
Now I want to change to Intel's C++ compiler, and have it downloaded and installed
(as part of Composer XE 2011).

My problem is that when, inside Visual Studio 2008,I change the compiler to be Intel's,
I get the following error message when building:

1>LINK : fatal error LNK1104: cannot open file 'libmmt.lib'

I don't get this error message when using Microsoft's C++ compiler.
Please tell me how to fix this.

Arne

0 Kudos
2 Replies
mecej4
Black Belt
57 Views

LIBMMT.lib is provided with the Intel compilers, and is installed in the Intel compiler's LIB directory. This library is not used by Microsoft C.

Just add that directory to the list of library directories to search in your project.
Manoj_Jangid
Beginner
57 Views

You need to add library path in Project settings-> Linker option
Reply