Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
7728 Discussions

Minimum gcc version for icpc 2021.2.0

Arthur4
Beginner
400 Views

Hello,

If I understand this correctly, the icpc compiler on Linux requires that gcc be installed. If my assumption is correct, what is the minimum gcc version that will work properly with icpc 2021.2.0? I am getting some compilation errors with gcc 4.8.3 installed, and I'm wondering whether this is my problem.

Thanks.

0 Kudos
1 Solution
HemanthCH_Intel
Moderator
376 Views

Hi,

Thanks for reaching out to us.


As per the Intel oneAPI C++ compiler system requirements, the minimum GCC version for using Intel C++ compiler is 4.8.5.


We see that you are using GCC version 4.8.3 which doesn't meet the system requirements.


So, we recommend you to use any of the supported GCC versions. For more information please refer to the below link.

https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-c-compiler-sys...


Thanks & Regards,

Hemanth Chintala.



View solution in original post

2 Replies
HemanthCH_Intel
Moderator
377 Views

Hi,

Thanks for reaching out to us.


As per the Intel oneAPI C++ compiler system requirements, the minimum GCC version for using Intel C++ compiler is 4.8.5.


We see that you are using GCC version 4.8.3 which doesn't meet the system requirements.


So, we recommend you to use any of the supported GCC versions. For more information please refer to the below link.

https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-c-compiler-sys...


Thanks & Regards,

Hemanth Chintala.



HemanthCH_Intel
Moderator
352 Views

Hi,


Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Thanks & Regards,

Hemanth.



Reply