Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Ashdown__Ian
Beginner
150 Views

Missing llvm_com

I installed Parallel Studio XE 2015 with MS Visual Studio 2013. When I ported an MSVC 2010 project, it compiled but failed to link with the cryptic error message "xilink: : error #10037: could not find 'llvm_com'". (It compiled correctly using MSVC 2010 with the Intel XE 2015 C++ compiler.)

The only reference to llvm in the Intel C++ documentation is to the Apple LLVM (Clang) compiler for XCode.

Any ideas?

 

0 Kudos
5 Replies
VERA_F_Intel
Employee
150 Views

Hi Ian A., 

Known bug, that will be fixed in next Composer XE 2015 update. 

Could you try to copy "mcpcom" to "llvm_com" as workaround?

Ian_A_
Beginner
150 Views

This is not particularly helpful.

1) We have no idea where the missing and undocumented llvm_com resides.

2) mcpcom (also undocumented in the Intel C++ compiler documentation) does not appear to be resident anywhere on our system.

3) If this is a "known bug," Intel does not appear to have documented it anywhere that we have been able to find.

4) Speaking of documentation, we have been unable to find any listing of Intel C++ compiler/linker error codes in the documentation.

5) The problem has occurred so far (for us) only with a massive project that would likely require weeks of work to isolate the cause of the linker error, let alone develop a workaround. The compiler works as expected with smaller projects.

Without any further information on the error message, its possible causes, and potential workarounds, we are essentially dead in the water until Intel releases an update. Our only option is to uninstall Intel Parallel Studio XE 2015 and revert to the earlier 2013 release (with its innumerable patches) until the issue is addressed.

TimP
Black Belt
150 Views

In the Windows installation, it's mcpcom.exe (should be in the same folder with icl.exe).

JenniferJ
Moderator
150 Views

Yeh, it's a known issue (DPD200359762). Another workaround is to not use /GL option, or build the full project with Intel C++ Compiler.

Jennifer

Ian_A_
Beginner
150 Views

The first solution from Vera F. worked.

To summarize, if you get the error message "xilink: : error #10037: could not find 'llvm_com'" when compiling and linking with Parallel Studio Composer XE 2015, the workaround is:

1.  Copy C:\Program Files (x86)\Intel\Composer XE 2015\bin\ia32\mcpcom.exe.

2.  Rename mcpcom - Copy.exe as llvm_copy.com.

This is for Win32 apps. For Win64 apps, do the same for ..bin\intel64\mcpcom.exe. (I have not tried the other three subdirectories of bin.)

I tried Jennifer J.'s workaround by disabling whole program optimization (Microsoft /GL option, Property Pages->Configuration Properties->General), and alternately building the whole solution (including exe, dll and lib files) with the Intel C++ compiler, but the linker still tried unsuccessfully to find llvm_com.exe.