Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Douglas_Albert
Beginner
206 Views

More Problems with Visual studio 2010 Integration

I've just downloaded C++ Composer XE for Windows and have installed it on Windows XP with Visual Studio 2010. Despite the fact that the properties of my project and all source files have been set to use the Intel compiler, I suspect that it is not being used. In my build log I get

MessageBuildingWithCompiler:

Building with Intel C++ Compiler XE 12.0

ClCompile:

***** ClCompile (X64 - Intel C++)

icl : warning #10199: IPO enabled; /Fa and /FA produce dummy .cod files

Microsoft C/C++ Optimizing Compiler Version 16.00.30319.01 for x64

Copyright (C) Microsoft Corporation. All rights reserved.

cl -D_M_AMD64

-D_M_X64

-D_WIN64

-D_MSC_VER=1600

-D_MSC_FULL_VER=160030319

-D_MSC_EXTENSIONS

-D_USE_ATTRIBUTES_FOR_SAL=0

-DSAL_NO_ATTRIBUTE_DECLARATIONS

-D_MT

-D_DLL

-D_WIN32

-D_export=

-D__w64=

-D__INTEL_COMPILER_BUILD_DATE=20101116

-D_INTEGRAL_MAX_BITS=64

...

"-IC:\\Program Files\\Intel\\ComposerXE-2011\\compiler\\include"

"-IC:\\Program Files\\Intel\\ComposerXE-2011\\compiler\\include\\Intel64"

"-IC:\\Program Files\\Microsoft Visual Studio 10.0\\VC\\include"

"-IC:\\Program Files\\Microsoft Visual Studio 10.0\\VC\\atlmfc\\include"

"-IC:\\Program Files\\Microsoft SDKs\\Windows\\v7.0A\\include"

-I\\include

-FIcilk/cilk_stub.h

-X

-Zc:forScope

-Zc:wchar_t

-EHs

-EHc

coosapi.c

-GR

-Zs

-FR.\\x64\\Release\\

-Tc..\\coosapi.c

-Tc..\\..\\BuildLevel\\bldlevel.c

-Tc..\\ProcMetric.c

coosapi.c

..\\coosapi.c: EVENTLOG routines included...

and also I get the warning

You are using an Intel supplied intrinsic header file with a third-party compiler.

In addition, I don't get the long link-time I usually get with Intel's multifile IPO.

0 Kudos
12 Replies
JenniferJ
Moderator
206 Views

The output msg is confusing.

did you install the full pkg with the Intel 64 compiler? When downloading, the IA32 pkg contains the compiler/libs for ia32 development only, the intel 64 pkg contains the compiler/libs for x64 development.

thanks,
Jennifer
Douglas_Albert
Beginner
206 Views

I installed the full version. I don't know how to double-check, but ComposerXE-2011\bin contains directories ia32, intel64, and ia32_intel64, among others, and these directories are populated with files. I am doing development for a 64-bit target on a 32-bit host. I've previously used older versions of Intel's compiler with older versions of Visual Studio, but I'm trying to upgrade both programs to the latest versions.

Douglas

Douglas_Albert
Beginner
206 Views

In addition, when I open Task Manager during a build, I find that cl is getting a high percentage of processor time and icl is getting none.
JenniferJ
Moderator
206 Views

how do you set the project or the file to be built with icl?

the steps should be:
1. for project - right click on the project name in the Project Explorer window, select "Intel C++ Composer XE 2011" -> "Use Intel C++"
2. for file - right click on the file name in the Project Explorer window, select "Intel C++ Composer XE 2011" -> "Use Intel C++"
3. then rebuild

Jennifer
Douglas_Albert
Beginner
206 Views

Yes, I followed that procedure. Now when I right-click on projects the Intel C++ Composer XE 2011 selection shows "Use Visual C++", as it should, to allow me to convert back to Microsoft's compiler. Right clicking on the solution file, all the project files, and the source files, all show that the Intel compiler has been selected, and the Properties selections all show Intel-specific options.

I have tried converting back to Microsoft, and then re-converting to Intel, but I still get the same problem with the Intel compiler.

I pulled the original source from Visual Source Safe and some of the source files are write-protected, but not the solution & project files. The copy itself is not under version control.

Douglas
JenniferJ
Moderator
206 Views

Hi Douglas,
is this project upgraded from an older .vcproj or .dsp project? It seems that there is a bug in the .vcxproj file.

could you attach the .vcxproj file only (private if preferred) that is not converted to IntelC yet?

thanks,
Jennifer
Douglas_Albert
Beginner
206 Views

Jennifer,

It's upgraded from an earlier .vcproj project. I've included the .vcxproj file in a private post.

Douglas
JenniferJ
Moderator
206 Views

There might be a bug in the IDE integration.

But I did find the work-around. The root cause is the /FR option - enable browse information. Turn it off, the additional msg will not be printed. This option is under Project Property-> C/C++ -> Browse Information.

There is a bug though. Our IDE integration shouldn't print out those extra out even if I've turned off /nologo. So I'll file a bug report about it.

Please use the work-around for now.

thanks for sending the .vcxproj file.
Jennifer

Douglas_Albert
Beginner
206 Views

Jennifer,

I tried the workaround and it worked! Thanks.

Douglas
206 Views

The issue is fixed in latest Intel C++ Composer XE 12.1. The composer is available for download from Intel download center. Now even with the switch /FR enabled there is no output from the Microsoft Compiler.

Thanks,
Alex

Giap_Huynh
Beginner
206 Views

Why C++ compiler doesn't show up in Visual Studio 2010 after Intel Composer XE was installed?

It should have both Fortran and C++ but only Fortran shows up. Does anyone know about this issue?

Thanks

Hubert_H_Intel
Employee
206 Views

Giap,

Looks like this is a duplicate to https://software.intel.com/en-us/forums/topic/514748. I'll follow up there and close this https://software.intel.com/en-us/comment/1787959) thread.

Regards, Hubert.

Reply