Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Iliyan_G_
Beginner
60 Views

Option to suppress xilink output messages?

Jump to solution

I'm using SCons to build a project with ICC on Windows, and I get a lot of xilink messages in the console that look like this:

xilink: executing 'link'
   Creating library path\to\file\file.lib and object path\to\file\file.exp

I believe these messages are output to stderr and are really polluting my console. I found no ICC option to suppress them. What's the proper way to do this, apart from the brute-force and sub-optimal forwarding of stderr output to NUL?

Thanks!

0 Kudos

Accepted Solutions
Kittur_G_Intel
Employee
60 Views

lliyan, the message "Creating library path\to\file\file.lib and object path\to\file\file.exp" comes from LINK.  I agree, although the message “"xilink: executing 'link'”” comes from xilink there’s no option available to disable it. BTW, there’s an issue filed on Xilink on a related issue sometime back to allow options to suppress messages. In  general, it does honor related options supported by LINK though.  Anyways, I’ll pass on the feedback to the developers and if need be file a feature request to disable such messages without a diagnostic number associated with it, thanks.

_Kittur 

View solution in original post

8 Replies
Kittur_G_Intel
Employee
60 Views

Hi lliyan,
You can disable diagnostics from xilink (which is the Intel pre-linker) using the diag-disable option. Refer to the table in the article on how to disable at:  https://software.intel.com/en-us/node/512838  You can add the disable (/Qdiag-disable:<diag-number> to the linker command Line > Additional Options field as well if running from VS as well)

_Kittur

 

Kittur_G_Intel
Employee
60 Views

Also, you can disable the dianostics from a complete phase as well (and not just a single diagnostic) as noted in the table (article link noted earlier).

_Kittur

Iliyan_G_
Beginner
60 Views

Thanks for the quick reply and the link, much appreciated! But I'm having trouble disabling this specific xilink message I'm referring to above. What option exactly should I use?

Actually, playing around with the /Qdiag-file option, it seems that

xilink: executing 'link'

is a different message from

Creating library ...

 

And when I add /Qdiag-file:output.txt only the second kind of messages are dumped to the file. xilink: executing 'link' is still output on the console.... Any idea how to get rid of both?

Kittur_G_Intel
Employee
60 Views

HI lliyan,
That's a good question. Unfortunately that error message is coming from MS Link and Intel compiler has no control on it at all. And I can't seem to find anyway you can control that output as well. May be, a good idea to give your feedback to MS to allow some option for disabling the same :-(
_Kittur

Iliyan_G_
Beginner
60 Views

Kittur Ganesh (Intel) wrote:
Unfortunately that error message is coming from MS Link and Intel compiler has no control on it at all.

Which message are you referring to? The "xilink: executing 'link'" message at least should come from ICC. Any way to disable that?

Kittur_G_Intel
Employee
61 Views

lliyan, the message "Creating library path\to\file\file.lib and object path\to\file\file.exp" comes from LINK.  I agree, although the message “"xilink: executing 'link'”” comes from xilink there’s no option available to disable it. BTW, there’s an issue filed on Xilink on a related issue sometime back to allow options to suppress messages. In  general, it does honor related options supported by LINK though.  Anyways, I’ll pass on the feedback to the developers and if need be file a feature request to disable such messages without a diagnostic number associated with it, thanks.

_Kittur 

View solution in original post

Iliyan_G_
Beginner
60 Views

Thanks, Kittur! Looking forward to having such an option.

Kittur_G_Intel
Employee
60 Views

Of course, thanks for bringing this up and I'll file a feature request with the developers and keep you updated accordingly.

_Kittur