Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
358 Views

[Parallel Studio XE 2020 U2, VS2019 16.8 preview 5] OffloadOpenMPTarget error.

I just ran into a problem that appears to be related to the settings of a project, building in a terminal a simple program seems to work, but the default project file for a Windows desktop application trips the error: The "OffloadOpenMPTarget=%(ClCompile.OffloadOpenMPTarget)" parameter for the "ICL" task is invalid.

Right now I'm unable to build anything via Visual Studio, and looking around the web I wasn't able to find anything at all, which makes me wonder if it has anything to do with my setup.

Is it known, or expected, already?

I'll attach a project file as well as the setup options for my Visual Studio 2019 Preview installation and Parallel Studio XE in case they're useful.

0 Kudos
9 Replies
Highlighted
Beginner
346 Views

For completeness, I just tried the current beta of the Intel C++ Compiler (v19.2, out of the oneAPI Data Parallel package), I'm getting the same error apparently.

ICL 19.2.png

0 Kudos
Highlighted
Moderator
326 Views

Hi James Russel,

Thanks for reaching out to us!


If possible, could you please provide steps to reproduce the issue you are facing?


Regarding: "For completeness, I just tried the current beta of the Intel C++ Compiler (v19.2, out of the oneAPI Data Parallel package), I'm getting the same error apparently."

Could you please provide more details about the oneAPI package you are referring to: are you referring to dpcpp compiler from oneAPI Base toolkit or Intel C++ Complier from oneAPI HPC toolkit?

Also, let us know the oneAPI beta version which you using.


Thanks & Regards

Goutham


0 Kudos
Highlighted
Moderator
319 Views

We have seen other issues with VS2019 16.8 preview 5.

Please see this thread https://community.intel.com/t5/Intel-C-Compiler/Visual-Studio-2019-16-8-preview-breaks-ICL-for-lt-ut...


0 Kudos
Highlighted
Beginner
311 Views

Thank you @GouthamK_Intel and @Viet_H_Intel for your insights, I had already stumbled upon the thread regarding the issues with the current beta, that's what led me to try the beta compiler present in the oneAPI package (the download in that thread is the one I mentioned @GouthamK_Intel )

I tried with the previous build (Preview 4 of VS2019 16.8) and the same error arises. I was able to replicate the issue in a virtual environment though, although the process may be tedious if its drive is not SSD based, but this would be the gist of it:

- Install a Windows 10 version in a VM.
- Install VS2019 Preview, the current one is fine and now that I think of it I haven't tried with its current stable version, I chose to import the configuration I uploaded to the first post to select the options I have in my current setup.
- Install Intel's C++ compiler, went for the current stable version for the test, but the beta bundled in the current oneAPI pre-production package behaved the same in a real environment.
- Open Visual Studio and create a new project, from the ones in there I just chose the default for C++ Desktop development which comes populated with some code already, produces a simple window with a menu.
- Switch to using the Intel compiler, I went with right clicking the project in the solution explorer and chose Use Intel C++.

Finally try to build the project, the error will appear, seems to be related to OpenMP somehow, checking the project files you can see OpenMP is disabled anyway.

If you wish I could try uploading the VM disk, but it's a 39GB download and it seems to be something easily reproducible.

0 Kudos
Highlighted
Beginner
308 Views

Initially I chose the Intel C++ Compiler from the HPC toolkit because I think it is the direct successor to that of the Parallel Studio XE, but I just tried the DPCPP one selecting "Intel C++ Compiler 2021" as the Platform Toolset in the Project Configuration and I got the same error.

I'd say it's some kind of missing configuration when switching to Intel toolsets, but that's where I'm of ideas.

The version of the oneAPI packages is 2021.1 Beta Update 9.

0 Kudos
Highlighted
Beginner
276 Views

I should have chosen a title that was more representative haha

Anyway, I gave it a try in another clean VM using the current stable version of VS2019 (16.7.7) and both XE 2020 Update 2 and the newly released Update 4 work as expected.

If the version of Visual Studio installed is 16.8 Preview 5 or Preview 6 neither the current stable version of Parallel Studio XE (Update 4) nor the newly released beta of the oneAPI kits are able to build via the IDE.

I get the same error as before and in the case of the oneAPI kits it doesn't matter if the compiler is set to be the traditional one from HPC or the data parallel one. I thought I should report again because both Microsoft and Intel made new releases.

0 Kudos
Highlighted
Moderator
261 Views

Hi James,

If the Visual Studio version which you are trying to use is released after the Intel Products (PSXE or oneAPI Base toolkits) release date then it is officially not supported. However, it might work.

We recommend you to use only those supported versions mentioned in the respective product documentation.

If we have answered your queries, let us know if we can close this thread.


Thanks & Regards

Goutham


0 Kudos
Highlighted
Beginner
255 Views

I understand, although both products claim to be compatible with Visual Studio 2019, what is going to happen when 16.8 is rolled out to the general public? I feel it's going to be soon seeing the cadence of the latest previews for 16.8.

I think it would be best to investigate why the recently released Update 4 for Parallel Studio XE and the current beta packages for the oneAPI related products can't be used with 16.8 preemptively.

From what I could see, seeing that the compilers are able to build executables and the like when ran through the command line, it seems to be something related to the code that switches a project from using Microsoft's compiler to Intel's via the GUI, or maybe a missing value for a property expected by the new Visual Studio build.

You may close the issue of course, I have verified it works as expected over 16.7, but if at all possible let the appropriate team something may be missing for 16.8 so it can be addressed before releasing new beta code for the oneAPI line which seems to be in full development.

Thanks for everything and for your time by the way!

Regards,
James.

0 Kudos
Highlighted
Moderator
236 Views

Hi James,

Thanks for your valuable feedback, we will forward your feedback to the concerned internal team.


Thanks for the confirmation!

As this issue has been resolved, we will no longer respond to this thread. 

If you require any additional assistance from Intel, please start a new thread. 

Any further interaction in this thread will be considered community only. 

Have a Good day!


Thanks & Regards

Goutham


0 Kudos