Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Manjeet_D_
Beginner
299 Views

Parallel Studio XE: ia32 on 64bit machine, ubuntu 14.04

Jump to solution

Hello,

I installed complete Parallel Studio XE (2016 update3, cluster edition) on ubuntu 14.04 x86-64 machine.

When I do following I get error:

% source /opt/intel/bin/compilervars.sh ia32

% /opt/intel/bin/icc -m32 -O0 test.c 

ld: cannot find -limf
ld: cannot find -lsvml
ld: cannot find -lirng
ld: cannot find -lipgo
ld: cannot find -ldecimal
ld: cannot find -lcilkrts
ld: cannot find -lirc
ld: cannot find -lsvml

I also checked in /opt/intel/lib (32 bit libraries are missing)

% ls /opt/intel/lib

 intel64  intel64_gfx  intel64_lin  intel64_lin_gfx  intel64_lin_mic  

Please help.

 

0 Kudos
1 Solution
Kittur_G_Intel
Employee
299 Views

Hi Manjeet,
I verified as well that it seems like ia32 target was not selected during the installation. By default only intel64 is selected, so you should explicitly enable ia32 in customized flow.  Try installing again, making sure the IA32 component is also selected as well and then verify that the directory (ia32) is created (which you mentioned was missing in your installation).  Let me know if it resolves the issue, appreciate much.

Regards,
Kittur

 

View solution in original post

7 Replies
Kittur_G_Intel
Employee
299 Views

Hi Manjeet,
I tried your scenario and don't have any issues. Can you make sure your environment is set correctly. Do the following:

1) Source the compilervars.sh from the bin directory like you mention
  % <installed directory>>/compilers_and_libraries_2016.3.210/linux/bin/compilervars.sh intel64

2) Check icc build version and environment is set correctly
  % icc -V
Intel(R) C Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 16.0.3.210 Build 20160415

3) echo $LD_LIBRARY_PATH
/cts/tools/compiler/cpro/Compiler/16.0/update3/compilers_and_libraries_2016.3.210/linux/mpi/intel64/lib:/cts/tools/compiler/cpro/Compiler/16.0/update3/compilers_and_libraries_2016.3.210/linux/ipp......and so on

4) icc -# -m32 hello.c >& out
% cat out
/...compilers_and_libraries_2016.3.210/linux/bin/intel64/mcpcom  \
    --lang=c \
    -_g \
....
...
    -L.../compilers_and_libraries_2016.3.210/linux/compiler/lib/ia32_lin \
and so on

5) %icc -m32 hello.c -o test
     % ./test.out
         "hello"

6) Now, the libraries that shows missing in your original issue description should be present in the directory:
<installed-dir>/compilers_and_libraries_2016.3.210/linux/compiler/lib/ia32
and the 64 bit libraries in:
<installed-dir>/compilers_and_libraries_2016.3.210/linux/compiler/lib/intel64

If you don't find those libraries in the above directories then your installation hasn't gone right. Please check the above steps and see if all works accordingly.

Regards,
Kittur

 

 

 


....

 

 

Manjeet_D_
Beginner
299 Views

In the 5th step I get following error:

ld: skipping incompatible /opt/intel/compilers_and_libraries_2016.3.210/linux/compiler/lib/intel64/libimf.a when searching for -limf
ld: skipping incompatible /opt/intel/compilers_and_libraries_2016.3.210/linux/daal/../compiler/lib/intel64_lin/libimf.a when searching for -limf
ld: skipping incompatible /opt/intel/compilers_and_libraries_2016.3.210/linux/compiler/lib/intel64//libimf.a when searching for -limf
ld: skipping incompatible /opt/intel/compilers_and_libraries_2016.3.210/linux/daal/../compiler/lib/intel64_lin//libimf.a when searching for -limf
ld: cannot find -limf
...so on

I don't even see the ia32 directory in my installation:

<installed-dir>/compilers_and_libraries_2016.3.210/linux/compiler/lib/ia32
 

However following one is present:

<installed-dir>/compilers_and_libraries_2016.3.210/linux/compiler/lib/intel64

What should I do to fix my installation?

 

Kittur_G_Intel
Employee
299 Views

Hi Manjeet,
During install did you do a custom install and deselect the ia32 component? Also, if you can attach the intel.*pset*.log and intel.*issa*.log that you find under the /tmp directory that would be great. It'll help us to investigate and see what's going on. The other option for you is to uninstall the installation (using ./uninstall.sh) under the bin directory and do a new installation again making sure the ia32 and intel64 targets are selected as well. Let me know how that goes but you can attach those log files for further investigation. Appreciate your patience through this.

Regards,
Kittur

Kittur_G_Intel
Employee
300 Views

Hi Manjeet,
I verified as well that it seems like ia32 target was not selected during the installation. By default only intel64 is selected, so you should explicitly enable ia32 in customized flow.  Try installing again, making sure the IA32 component is also selected as well and then verify that the directory (ia32) is created (which you mentioned was missing in your installation).  Let me know if it resolves the issue, appreciate much.

Regards,
Kittur

 

View solution in original post

Manjeet_D_
Beginner
299 Views

Thanks choosing ia32 worked. I thought it is chosen by default on complete installation.

Kittur_G_Intel
Employee
299 Views

Great, glad to know it's resolved now Manjeet.  Again, appreciate your patience throughout this issue.

Kittur

TimP
Black Belt
299 Views

By the way, the Ubuntu subsystem in Windows 10 also goes by the same name, but there is no support for 32-bit mode, and it doesn't look like it will be possible to install Intel linux compilers even for Intel64.  The legacy way of using alien to make .deb fails on account of the k1om shared objects (and possibly other reasons, including no support for GUI).

For what it's worth, it looks like it will be possible to update these Ubuntu 64-bit variants to current gcc, although there are some poorly documented obstacles.  I don't think that is the main blocking factor on using the Intel compilers.

Reply