Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Gordon_S_
Beginner
87 Views

Problem with static constexpr member array

Good day. 

This code:

-------------------------------   test.c++

#include<array>

struct A { static constexpr std::array<int, 3> data {{ 2, 3, 2}}; };

int main(){}

 ------------------------------

 is compiled just fine with gcc 4.7.1, but the latest (13.1.2.146) icc version returns an error (expected ";" after "data")

command lines:

g++-4.7.1 -std=c++11 test.c++

and 

icc  -std=c++11 test.c++ 

 A you going to fix it? And when.

 Regards

0 Kudos
4 Replies
Judith_W_Intel
Employee
87 Views

 

We have only partially implemented the constexpr feature (just enough so that the uses in the GNU headers will work correctly) so it looks like this shows some of the incomplete implementation. I have entered DPD200241235 to track this problem and we will let you know when it is resolved.

thanks for reporting it. 

Gordon_S_
Beginner
87 Views

Judith Ward (Intel) wrote:

 We have only partially implemented the constexpr feature (just enough so that the uses in the GNU headers will work correctly) so it looks like this shows some of the incomplete implementation. I have entered DPD200241235 to track this problem and we will let you know when it is resolved.

thanks for reporting it. 

Thanks for responce.

What is DPD200241235, and where can I track it?

And could you say, please, when do you plan to implement full C++11 support? Can I expect it in this year?

Judith_W_Intel
Employee
87 Views

 

Sorry but we can't comment on future plans. Let's just say full c++11 support is very high priority for us. DPD200241235 is a number from our internal bug tracking database. If you wish to be able to track the progress of this bug I would suggest you enter an official bug report through Intel Premier Support. Please let them know about the internal tracking number so they don't reenter it.

thanks,

Judy

JenniferJ
Moderator
87 Views

Hello,

This issue has been fixed in the 14.0 update 4 and 15.0.

Try it out, thanks!

Jennifer

Reply