Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

Problem with xilib

___
Beginner
170 Views
Hi guys. I have a static library project in VS 2005 using Intel C++ Compiler 11.

When I rebuild the project, all things goes fine, but no output library found in the output directory.

The VS build output window shows:

1>Creating library... (Intel C++ Environment)
1>xilib: executing 'lib'
1>Build log was saved at "file://E:\Projects\mp4lib\Debug\BuildLog.htm"
1>mp4lib - 0 error(s), 63 warning(s)
========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========

The output log:
Creating temporary file "C:\DOCUME~1\GliderX\LOCALS~1\Temp\RSP337.bs" with contents
[
/c /O2 /I "..\common" /I "..\x264\extra" /I "..\x264" /I "..\avilib" /I "..\xvidcore\src" /I "..\libfaac\include" /D "WIN32" /D "NDEBUG" /D "_LIB" /D "_UNICODE" /D "UNICODE" /MD /GS /fp:fast /Fo"Release/" /W3 /nologo /Wp64 /Zi /Qvc8 /Qlocation,link,"F:\Program Files\Microsoft Visual Studio 8\VC\bin"
.\mp4enc.c
.\h264enc.c
.\cvtaac.c
]
Creating command line "icl.exe "@C:\DOCUME~1\GliderX\LOCALS~1\Temp\RSP337.bs""
Creating temporary file "C:\DOCUME~1\GliderX\LOCALS~1\Temp\RSP33A.bs" with contents
[
/OUT:"E:\Projects\mp4lib\Release/mp4lib.lib" /nologo
Release/cvtaac.obj
Release/h264enc.obj
Release/mp4enc.obj
]
Creating command line "xilib.exe "@C:\DOCUME~1\GliderX\LOCALS~1\Temp\RSP33A.bs""


Any suggestion? Thanks.
0 Kudos
2 Replies
Om_S_Intel
Employee
170 Views

Could you please share the test case?

JenniferJ
Moderator
170 Views
Quoting - ? ?
Creating temporary file "C:DOCUME~1GliderXLOCALS~1TempRSP33A.bs" with contents
[
/OUT:"E:Projectsmp4libRelease/mp4lib.lib" /nologo
Release/cvtaac.obj
Release/h264enc.obj
Release/mp4enc.obj
]
Creating command line "xilib.exe "@C:DOCUME~1GliderXLOCALS~1TempRSP33A.bs""

Did you look at the dir "E:Projectsmp4libRelease" for the .lib file?

Which update of 11.0 are you using? I tried 11.0.066, no problem with it. My project is on "D:".

Jennifer
Reply