Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Sunanda_C_
Beginner
60 Views

Problems with Visual Studio 2013 integration

I've just downloaded C++ Composer XE 2013 (trial version) for Windows and have installed it on Windows 7 with Visual Studio 2013. Despite the fact that the properties of my project and all source files have been set to use the Intel compiler(14.0), it is not being used.

I have explicitly used "Intel Composer XE 2013 SP1"-> "Use Intel C++" option as well and following message comes:

    Platform "Win32" has been updated to use the Intel C++ compiler successfully.
    Platform "x64" has been updated to use the Intel C++ compiler successfully.
========== Done ==========

After this when I rebuild my project still following logs comes which suggest Intel compiler is not being used:

Microsoft (R) C/C++ Optimizing Compiler Version 18.00.30723 for x86
1>  Copyright (C) Microsoft Corporation.  All rights reserved.
1>  
1>  cl /c ......

Is there some setting I missed? Changes are reflected in .vcxproj.

0 Kudos
5 Replies
Hubert_H_Intel
Employee
60 Views

Did you really download the old version 2013 SP1 of the Intel® C++ Composer XE? Do you need to evaluate this version? If there are no objections, pleaes uninstall the Composer XE 2013 SP1 via Control Panel and reinstall the actual Intel® Parallel Studio XE Composer Edition 2015 for Windows* from the Intel® Registration Center. If you need help with this, let me know.

Regards, Hubert.

Sunanda_C_
Beginner
60 Views

Thanks for your reply Hubert. yes I downloaded 2013 SPI of the Intel® C++ Composer XE. Meanwhile, I have uninstalled it and tried to build using 2011 version (12.1), since I am using this compiler successfully for Visual Studio 2010 projects. Still I am facing same issue for VS 2013.

1. On further investigation I found that $(PlatformToolset)= v120 even after completing earlier mentioned steps. That is why incorrect compiler is chosen. Surprisingly, in "Configuration Properties" -> "General" -> "Platform Toolset" is "Intel C++ Compiler XE 12.1".

2. With Intel 2013 I was getting this option (Right-click on a project,  > Intel Composer XE <version> > Use Intel C++). But with Intel 12.1 version installed "Intel Composer XE <version>" is not coming now. Any thoughts on this?

Regards, Sunanda

Sunanda_C_
Beginner
60 Views

Hi Hubert,

In meantime I have tried following steps:

1. Uninstall all Intel C++ compiler versions

2. VS 2010 and VS 2013 are already installed

3. Now install Intel C++ Compiler 2015 (I have valid license file).

4. Right click and set "Use Intel C++" and check that changes are reflected in .vcxproj file as well

5. Macros are:

BasePlatformToolset=v120, DefaultIntelPlatformToolset=Intel C++ Compiler XE 15.0, PlatformToolset=v120, PlatformToolsetVersion=120

Still Intel Compiler is not being used for compilation. I think "PlatformToolset" is incorrectly set. Please advise

 

 

Hubert_H_Intel
Employee
60 Views

Sunanda,

The macro settings look ok.

What do the log files under (e.g. for a 64-bit release) <projectname>\x64\Release\<projectname>.log

show? Is cl or icl being invoked for compilation?

Hubert.

 

Sunanda_C_
Beginner
60 Views

It shows cl being used.

I think I got the issue. I added a <projectname>.props file in projects "Property Manager" tab. In this file added PlatformToolset tag and it worked. Now icl is being used. Don't know why .vcxproj settings are not taking effect. Thank you for the help.

 

Reply