Community
cancel
Showing results for 
Search instead for 
Did you mean: 
smoked_trout
Beginner
87 Views

/Qipo causes full link?

Hi,

I have a large solution I converted from VS 2008 w/Intel C++ 11.1 to VS 2010 and Composer XE 2011

I was always experiencing a complete re-link with my Release configurations. I have found that disabling Interprocedural Optimizations or simply switching to Single-File things act as desired, but anytime I select Multi-File (/Qipo) the project must generate an ipo#####.obj file and relink the project.

I did not experience this behavior with 11.1/VS 2008

Is this by design, or have I missed something?

Thanks

0 Kudos
2 Replies
mecej4
Black Belt
87 Views

We do not know what, if any, changes were made to the project settings as a result of the conversion from VS2008 to VS2010.

If possible, obtain and compare the build logs from the old and new versions of the projects, especially the compiler and linker invocation lines.
smoked_trout
Beginner
87 Views

Sorry for the delay was on vacation...

Anyway, I noticed nothing major in the log files.

So, I decided to recreate the solution from scratch to avoid the upgrade issues.

Created the solution, added the necessary files, and rebuilt it just fine. Turned on Multifile Interprocedural Optimization and now the project rebuilds every time. So I can eliminate the upgrade procedure as the problem.

Using DebugView to capture linker traces, I always see a line similar to this near the beginning:

Project 'F:\Source\FSIM2\FSIM\FSIM.vcxproj' not up to date because 1 build outputs were missing.
up to date is missing 'F:\SOURCE\FSIM2\FSIM\IPO_30925OBJ.OBJ'

And then the project links. Same message every time except the numbers for the IPO_XXXXXXOBJ.OBJ file change.

Reply